aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-09-23 08:00:55 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:24 +0200
commitfd9f63aad15ef0bd7b13361c8399f360d4d518ec (patch)
tree3359c6bdfa4d3a4d27263b086cdf61ca2569c4e7 /meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
parentf73a8d62659fac2245f6dcb991940741afce44c7 (diff)
downloadmeta-openembedded-fd9f63aad15ef0bd7b13361c8399f360d4d518ec.tar.gz
libhugetlbfs: add recipe
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
new file mode 100644
index 0000000000..7835300795
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "A library which provides easy access to huge pages of memory"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "sysfsutils perl"
+RDEPENDS_${PN} += "python python-io python-lang python-subprocess python-resource"
+
+SRCREV = "49fedbe172343b3f7b39dc81bd2d81a18a34eb2f"
+SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
+ file://aarch64-support.patch \
+ file://aarch64-unit-test-fixes.patch \
+ file://add-PROT-NONE-to-the-mprotest-test.patch \
+ file://install64-fix.patch \
+ file://skip-checking-LIB32-and-LIB64-if-they-point-to-the-s.patch \
+ file://libhugetlbfs-avoid-search-host-library-path-for-cros.patch \
+ file://fix-lib64-can-not-be-shiped-in-64bit-target.patch \
+"
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*"
+
+
+EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' BUILDTYPE=NATIVEONLY ${LIBARGS}"
+CFLAGS += "-fexpensive-optimizations -frename-registers -fomit-frame-pointer -g0"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+#The CUSTOM_LDSCRIPTS doesn't work with the gold linker
+do_configure() {
+ if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+ sed -i 's/CUSTOM_LDSCRIPTS = yes/CUSTOM_LDSCRIPTS = no/' Makefile
+ fi
+}
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} \
+ INST_TESTSDIR32=/opt/libhugetlbfs/tests \
+ INST_TESTSDIR64=/opt/libhugetlbfs/tests \
+ install-tests
+}
+
+PARALLEL_MAKE_pn-${PN} = ""
+
+PACKAGES =+ "${PN}-perl ${PN}-tests ${PN}-perl5"
+FILES_${PN}-dbg += "${libdir}/libhugetlbfs/tests/obj32/.debug ${libdir}/libhugetlbfs/tests/obj64/.debug"
+FILES_${PN}-perl = "${libdir}/perl"
+FILES_${PN}-perl5 = "${libdir}/perl5 "
+FILES_${PN}-tests += "/opt/libhugetlbfs/tests"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"