aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2020-03-13 18:16:29 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-13 10:57:21 -0700
commitd104def001dba5c246abef6bc9f4e5f766b429d8 (patch)
tree326a91e8c4dc520b686ce0cb1fa38edc2adb5e0d /meta-oe/recipes-benchmark
parenta76744d8ba6cf6be4a2131f79396ea3a9e1271bd (diff)
downloadmeta-openembedded-d104def001dba5c246abef6bc9f4e5f766b429d8.tar.gz
fio: disable compiler optimizations for x86 arch
with compiler optimizations enabled, "fio --help" will failed with "Illegal instruction" on Intel Denverton board. Enable it on condition that MACHINE_FEATURES include x86. Related commits: https://git.openembedded.org/meta-openembedded/commit/?id=c58d9d500f90246d2d879e720fdfa5bbbc731c7f https://git.openembedded.org/meta-openembedded/commit/?id=739349da0826221f98648b64b693f9ae33e7d4ea Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.17.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.17.bb b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
index b65ab19a3e..759d1087c0 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.17.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
@@ -34,6 +34,7 @@ S = "${WORKDIR}/git"
DISABLE_STATIC = ""
EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
+EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
do_configure() {
./configure ${EXTRA_OECONF}