aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorSlater, Joseph <joe.slater@windriver.com>2020-02-27 13:49:12 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-27 17:24:19 -0800
commit1b8d355149f97e981aabb9be2221359089ef7c60 (patch)
tree8a8b03e7e9036210dd445e66e7b28b9f0a70c3f2 /meta-oe/recipes-benchmark
parent14eb47687eb9f4bd9847eb9e6527fe75bd8e77a4 (diff)
downloadmeta-openembedded-1b8d355149f97e981aabb9be2221359089ef7c60.tar.gz
fio: change four python shebangs
Use python3. Note that the recipe already depends on python3-core at runtime. We only change scripts that show up under /usr/bin. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch38
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.17.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch b/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch
new file mode 100644
index 0000000000..068b021644
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/files/python3_shebangs.patch
@@ -0,0 +1,38 @@
+python3: change four shebangs to python3
+
+Upstream-Status: Pending
+
+Signed-off-by: Joe Slater <joe.slater@windriver.com>
+
+--- a/tools/fio_jsonplus_clat2csv
++++ b/tools/fio_jsonplus_clat2csv
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # Note: this script is python2 and python3 compatible.
+ #
+ # fio_jsonplus_clat2csv
+--- a/tools/fiologparser.py
++++ b/tools/fiologparser.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # Note: this script is python2 and python 3 compatible.
+ #
+ # fiologparser.py
+--- a/tools/hist/fiologparser_hist.py
++++ b/tools/hist/fiologparser_hist.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ """
+ Utility for converting *_clat_hist* files generated by fio into latency statistics.
+
+--- a/tools/plot/fio2gnuplot
++++ b/tools/plot/fio2gnuplot
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # Note: this script is python2 and python3 compatible.
+ #
+ # Copyright (C) 2013 eNovance SAS <licensing@enovance.com>
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.17.bb b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
index b15d7ba073..b65ab19a3e 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.17.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
@@ -25,6 +25,7 @@ PACKAGECONFIG[numa] = ",--disable-numa,numactl"
SRCREV = "08ce9dc20b8a4e55db7af6d869ddfa49b4a02d03"
SRC_URI = "git://git.kernel.dk/fio.git \
file://0001-update-the-interpreter-paths.patch \
+ file://python3_shebangs.patch \
"
S = "${WORKDIR}/git"