aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-07-25 14:31:10 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-26 14:29:17 -0700
commit7aeac572dee32c28ee0f5125582920362d12da3e (patch)
tree7c686c2aa987f03c2b3fac54cd62bf441e7ae43e /meta-oe/recipes-bsp
parentf69833e658a1abb1dd0082d3007b78e08a877c7f (diff)
downloadmeta-openembedded-7aeac572dee32c28ee0f5125582920362d12da3e.tar.gz
lmsensors: support package lmsensors
Recipe lmsensors has multiple packages, but do not provide package lmsensors. The fix will allow package lmsensors empty, and it runtime depends on other sub packages. It is convenience for Yocto new user to install all of them by specifying one package, especially the package name is the same with recipe name Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb
index c8e4565c16..b4fcfe3edb 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb
@@ -70,6 +70,18 @@ do_install() {
RPROVIDES_${PN}-dbg += "${PN}-libsensors-dbg ${PN}-sensors-dbg ${PN}-sensord-dbg ${PN}-isatools-dbg"
+ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN} += " \
+ ${PN}-libsensors \
+ ${PN}-sensors \
+ ${PN}-sensord \
+ ${PN}-fancontrol \
+ ${PN}-sensorsdetect \
+ ${PN}-sensorsconfconvert \
+ ${PN}-pwmconfig \
+ ${PN}-isatools \
+"
+
# libsensors packages
PACKAGES =+ "${PN}-libsensors ${PN}-libsensors-dev ${PN}-libsensors-staticdev ${PN}-libsensors-doc"