aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 10:01:17 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 12:59:52 +0100
commite2b5b7e2464c4ffe4b3c11a222d0760baad809dd (patch)
treee383877067757ff7e4f3a245e5502fa17d6a262b /meta-oe/recipes-connectivity/gateone/gateone_git.bb
parent409d1973152d4b75146d0ff58b1857a12e500cf7 (diff)
downloadmeta-openembedded-e2b5b7e2464c4ffe4b3c11a222d0760baad809dd.tar.gz
gateone: add git version
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
new file mode 100644
index 0000000000..65e7190257
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec"
+
+PR = "r3"
+
+PV = "0.9"
+SRCREV = "3a10118f10aeea457be0cbea89a5e1e642fbf59f"
+SRC_URI = "git://github.com/liftoff/GateOne.git"
+
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+do_configure_prepend() {
+ sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py
+}
+
+FILES_${PN} = "${localstatedir}/lib/"
+RDEPENDS_${PN} = "python-tornado \
+ python-datetime \
+ python-shell \
+ python-subprocess \
+ python-terminal \
+ python-io \
+ python-compression \
+ python-syslog \
+ python-misc \
+ python-crypt \
+ python-netclient \
+ python-email \
+ python-html \
+ python-textutils \
+ python-pyopenssl \
+ findutils \
+ python-simplejson \
+ "