aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-09 12:51:30 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-09 12:51:30 +0100
commitdb658e9954586f209c9ad3737c7f7488065ece38 (patch)
treec1b26fbd64215b0b5778aefcef9bf103c70b2da0 /meta-oe/recipes-connectivity/gateone/gateone_git.bb
parente5d7b0b90c71b986cdda3319b2a3be03254144b2 (diff)
downloadmeta-openembedded-db658e9954586f209c9ad3737c7f7488065ece38.tar.gz
gateone: make it work
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index 65e7190257..fdccadd550 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,10 +2,10 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
LICENSE = "AGPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec"
-PR = "r3"
+PR = "r5"
PV = "0.9"
-SRCREV = "3a10118f10aeea457be0cbea89a5e1e642fbf59f"
+SRCREV = "031a85e8e24ae499e41e15b5077c33a4bd647bd3"
SRC_URI = "git://github.com/liftoff/GateOne.git"
S = "${WORKDIR}/git"
@@ -16,7 +16,11 @@ do_configure_prepend() {
sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py
}
-FILES_${PN} = "${localstatedir}/lib/"
+do_install_append() {
+ install -d ${D}${localstatedir}/log/${BPN}
+}
+
+FILES_${PN} = "${localstatedir}"
RDEPENDS_${PN} = "python-tornado \
python-datetime \
python-shell \
@@ -34,4 +38,8 @@ RDEPENDS_${PN} = "python-tornado \
python-pyopenssl \
findutils \
python-simplejson \
+ python-multiprocessing \
+ file \
+ openssh-ssh \
+ mime-support \
"