aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/hostapd
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2015-12-19 20:22:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:55:18 +0100
commit6bdf80f70b54a5904b48e2346505d82e8c635350 (patch)
treee9331b0dced5fcba68aeb57116acf8963634f4c2 /meta-oe/recipes-connectivity/hostapd
parent4b358f9475954ca678a2611e9312fb65f534fb5b (diff)
downloadmeta-openembedded-6bdf80f70b54a5904b48e2346505d82e8c635350.tar.gz
hostapd: Fix source and build directory
The current recipe make no difference between the source and the build directory. There are source files outside this directory and isn't possible to patch these files. This changes adds the build directory path to the recipe, now is possible to patch files in other directories, if required. Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
index d95dbec27b..c38e20a723 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
@@ -1,7 +1,7 @@
HOMEPAGE = "http://w1.fi/hostapd/"
SECTION = "kernel/userland"
LICENSE = "GPLv2 | BSD"
-LIC_FILES_CHKSUM = "file://README;md5=4d53178f44d4b38418a4fa8de365e11c"
+LIC_FILES_CHKSUM = "file://${B}/README;md5=4d53178f44d4b38418a4fa8de365e11c"
DEPENDS = "libnl openssl"
SUMMARY = "User space daemon for extended IEEE 802.11 management"
@@ -18,11 +18,11 @@ SRC_URI = " \
file://hostapd.service \
"
-S = "${WORKDIR}/hostapd-${PV}/hostapd"
-
+S = "${WORKDIR}/hostapd-${PV}"
+B = "${WORKDIR}/hostapd-${PV}/hostapd"
do_configure() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ install -m 0644 ${WORKDIR}/defconfig ${B}/.config
}
do_compile() {
@@ -32,9 +32,9 @@ do_compile() {
do_install() {
install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
- install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
- install -m 0755 ${S}/hostapd ${D}${sbindir}
- install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
+ install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
+ install -m 0755 ${B}/hostapd ${D}${sbindir}
+ install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service