aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2020-02-04 20:23:08 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-04 22:03:14 -0800
commit3db4cc73509f5b624f48603e80e53d7fff0d5fe3 (patch)
tree72864dce5e1249ac6eeab48a541601dfea3d46ec /meta-oe/recipes-connectivity/iwd
parente2bf7b572c2e47b838dde2112f4af91f3da10cea (diff)
downloadmeta-openembedded-3db4cc73509f5b624f48603e80e53d7fff0d5fe3.tar.gz
iwd: Use manpages class to control documentation
This class allows the api-documentation distro feature to control man page generation. Remove copying all .txt files from ${S}/doc since these are developer documents and wouldn't be of any use to users on the target device. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index cfced50a0e..9d63e5b73b 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Wireless daemon for Linux"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
-inherit autotools pkgconfig systemd python3native
+inherit autotools manpages pkgconfig systemd python3native
DEPENDS = "ell"
@@ -16,12 +16,11 @@ S = "${WORKDIR}/git"
PACKAGECONFIG ??= " \
client \
monitor \
- manual-pages \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
"
PACKAGECONFIG[client] = "--enable-client,--disable-client,readline"
PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor"
-PACKAGECONFIG[manual-pages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
+PACKAGECONFIG[manpages] = "--enable-manual-pages,--disable-manual-pages,python3-docutils-native"
PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
@@ -33,8 +32,6 @@ do_configure_prepend () {
}
do_install_append() {
- mkdir --parents ${D}${docdir}/${BPN}
- install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN}
# If client and monitor are disabled, bindir is empty, causing a QA error
rmdir --ignore-fail-on-non-empty ${D}/${bindir}
}