aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2020-02-04 20:23:09 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-04 22:03:14 -0800
commit68aa2eab38a0cf9d5eca58ba95ff4ffec7f1457b (patch)
treeafb4b884a17bf5506022e92d46895a8ef193d7ca /meta-oe/recipes-connectivity/iwd
parent3db4cc73509f5b624f48603e80e53d7fff0d5fe3 (diff)
downloadmeta-openembedded-68aa2eab38a0cf9d5eca58ba95ff4ffec7f1457b.tar.gz
iwd: Update formatting
Try to conform better to the style guide. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb35
1 files changed, 22 insertions, 13 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index 9d63e5b73b..f758781e38 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -1,18 +1,20 @@
-DESCRIPTION = "Wireless daemon for Linux"
+SUMMARY = "Wireless daemon for Linux"
+HOMEPAGE = "https://iwd.wiki.kernel.org/"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
-inherit autotools manpages pkgconfig systemd python3native
-
DEPENDS = "ell"
-SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
- file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
- file://0001-build-Support-missing-rawmemchr.patch \
- "
+SRC_URI = " \
+ git://git.kernel.org/pub/scm/network/wireless/iwd.git \
+ file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
+ file://0001-build-Support-missing-rawmemchr.patch \
+"
SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
S = "${WORKDIR}/git"
+inherit autotools manpages pkgconfig python3native systemd
+
PACKAGECONFIG ??= " \
client \
monitor \
@@ -25,10 +27,15 @@ PACKAGECONFIG[wired] = "--enable-wired,--disable-wired"
PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono"
PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd"
-EXTRA_OECONF += "--enable-external-ell"
+EXTRA_OECONF = "--enable-external-ell"
-do_configure_prepend () {
- mkdir -p ${S}/build-aux
+SYSTEMD_SERVICE_${PN} = " \
+ iwd.service \
+ ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)} \
+"
+
+do_configure_prepend() {
+ install -d ${S}/build-aux
}
do_install_append() {
@@ -36,9 +43,11 @@ do_install_append() {
rmdir --ignore-fail-on-non-empty ${D}/${bindir}
}
-FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/"
-
-SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}"
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${nonarch_libdir}/modules-load.d \
+ ${systemd_unitdir}/network \
+"
RDEPENDS_${PN} = "dbus"