aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/krb5
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-05-11 09:41:31 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-19 12:02:39 +0200
commit5da9408672d3929d2f71d0b15a8e06043c5a1109 (patch)
treeab7383030f8560a1e8c8d20383e37d9216a86133 /meta-oe/recipes-connectivity/krb5
parent87084feb1e29fe6ff4d9ecf589219343e6eea158 (diff)
downloadmeta-openembedded-5da9408672d3929d2f71d0b15a8e06043c5a1109.tar.gz
krb5: fix uninitialized variable warning
On some targets clang erroniously detects an uninitialized variable. Backport the fix from upstream. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/krb5')
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5/0001-Work-around-uninitialized-warning-in-cc_kcm.c.patch37
-rw-r--r--meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/krb5/krb5/0001-Work-around-uninitialized-warning-in-cc_kcm.c.patch b/meta-oe/recipes-connectivity/krb5/krb5/0001-Work-around-uninitialized-warning-in-cc_kcm.c.patch
new file mode 100644
index 0000000000..c6731a9002
--- /dev/null
+++ b/meta-oe/recipes-connectivity/krb5/krb5/0001-Work-around-uninitialized-warning-in-cc_kcm.c.patch
@@ -0,0 +1,37 @@
+From f1b681a44d28946e6d8fc0080f3efe94228d7dfe Mon Sep 17 00:00:00 2001
+From: Tom Yu <tlyu@mit.edu>
+Date: Wed, 6 Jan 2016 15:24:16 -0500
+Subject: [PATCH] Work around uninitialized warning in cc_kcm.c
+
+Some versions of clang erroneously detect use of an uninitialized
+variable reply_len in kcmio_call() when building on non-Mac platforms.
+Initialize it to work around this warning.
+
+(cherry picked from commit 40b007c0d8e2a12c6f4205ac111dee731c9d970c)
+
+ticket: 8335
+version_fixed: 1.13.4
+tags: -pullup
+status: resolved
+
+Upstream-Status: backport
+---
+ src/lib/krb5/ccache/cc_kcm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/krb5/ccache/cc_kcm.c b/src/lib/krb5/ccache/cc_kcm.c
+index b763ea4..6337b57 100644
+--- a/src/lib/krb5/ccache/cc_kcm.c
++++ b/src/lib/krb5/ccache/cc_kcm.c
+@@ -377,7 +377,7 @@ static krb5_error_code
+ kcmio_call(krb5_context context, struct kcmio *io, struct kcmreq *req)
+ {
+ krb5_error_code ret;
+- size_t reply_len;
++ size_t reply_len = 0;
+
+ if (k5_buf_status(&req->reqbuf) != 0)
+ return ENOMEM;
+--
+2.8.2
+
diff --git a/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb b/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
index 713b76c080..0c566cbc24 100644
--- a/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
+++ b/meta-oe/recipes-connectivity/krb5/krb5_1.13.2.bb
@@ -33,6 +33,7 @@ SRC_URI = "http://web.mit.edu/kerberos/dist/${BPN}/${SHRT_VER}/${BP}-signed.tar
file://etc/default/krb5-kdc \
file://etc/default/krb5-admin-server \
file://krb5-CVE-2016-3119.patch;striplevel=2 \
+ file://0001-Work-around-uninitialized-warning-in-cc_kcm.c.patch;striplevel=2 \
"
SRC_URI[md5sum] = "f7ebfa6c99c10b16979ebf9a98343189"
SRC_URI[sha256sum] = "e528c30b0209c741f6f320cb83122ded92f291802b6a1a1dc1a01dcdb3ff6de1"