aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/ptpd
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2011-12-21 06:01:43 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-22 08:49:16 +0100
commitca8183238a6bea0922f8416444741244cc8d14c7 (patch)
treee93ddb77f6eb4a53a06037067b5c9e6abf805926 /meta-oe/recipes-connectivity/ptpd
parent713b8ac8aaae7b6cd2c97801bc8575323846fee7 (diff)
downloadmeta-openembedded-ca8183238a6bea0922f8416444741244cc8d14c7.tar.gz
ptpd: add version 1.0.0
Precision Time Protocol (PTP) as defined by the IEEE 1588 standard. Signed-off-by: Zhenhua Luo <b19537@freescale.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/ptpd')
-rw-r--r--meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch26
-rw-r--r--meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb20
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch b/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch
new file mode 100644
index 0000000000..8ed3f2f977
--- /dev/null
+++ b/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch
@@ -0,0 +1,26 @@
+ptpd: fix ftbfs by including limits.h so MAX_INT defined
+
+The current recipe for ptpd fails to build with:
+
+| arith.c: In function 'fromInternalTime':
+| arith.c:46: error: 'INT_MAX' undeclared (first use in this function)
+| arith.c:46: error: (Each undeclared identifier is reported only once
+| arith.c:46: error: for each function it appears in.)
+| arith.c: In function 'toInternalTime':
+| arith.c:64: error: 'INT_MAX' undeclared (first use in this function)
+| make: *** [arith.o] Error 1
+| make: *** Waiting for unfinished jobs....
+| FATAL: oe_runmake failed
+
+diff --git a/src/arith.c b/src/arith.c
+--- a/src/arith.c
++++ b/src/arith.c
+@@ -1,6 +1,7 @@
+ /* arith.c */
+
+ #include "ptpd.h"
++#include <limits.h>
+
+ /* from annex C of the spec */
+ UInteger32 crc_algorithm(Octet *buf, Integer16 length)
+
diff --git a/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb b/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb
new file mode 100644
index 0000000000..08e1b6bab8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Precision Time Protocol (PTP) as defined by the IEEE 1588 standard"
+HOMEPAGE = "http://sourceforge.net/projects/ptpd"
+SECTION = "network"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://../COPYRIGHT;md5=888bd1b2c9c013b93394b8bfb453c417"
+
+SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${PV}/ptpd-${PV}.tar.gz \
+ file://add-limit-h.patch;striplevel=2"
+
+SRC_URI[md5sum] = "b112b2bedc7f6e6e11a838608b9e0357"
+SRC_URI[sha256sum] = "8ac1fdcad1e246b0395097dd9af29966c6823533d7e6989aae91506048fb51bc"
+
+S = "${WORKDIR}/ptpd-${PV}/src"
+
+do_install() {
+ install -d ${D}${bindir} ${D}${mandir}/man8
+ install -m 4555 ptpd ${D}${bindir}
+ install -m 644 ptpd.8 ${D}${mandir}/man8
+}