aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/samba/samba_3.5.6.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-13 13:58:15 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-13 14:37:53 +0200
commitafd70256706ccd1ea416636eb61cb5160cffbe3c (patch)
treef64e7525c4bb9a192a180bb804c8c205384a8ffa /meta-oe/recipes-connectivity/samba/samba_3.5.6.bb
parent2ccf9373c1d8e03cad11b06ac2b4fe545e92f604 (diff)
downloadmeta-openembedded-afd70256706ccd1ea416636eb61cb5160cffbe3c.tar.gz
samba 3.5.6: import from OE rev a54456425ea3ce4c7cdfa958cec3ba34539cfeec
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba_3.5.6.bb')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_3.5.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba_3.5.6.bb b/meta-oe/recipes-connectivity/samba/samba_3.5.6.bb
new file mode 100644
index 0000000000..d5945f9622
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba_3.5.6.bb
@@ -0,0 +1,33 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI += "file://config-h.patch \
+ file://tdbheaderfix.patch;patchdir=.."
+
+SRC_URI[md5sum] = "bf6c09ea497a166df8bd672db1d8da8f"
+SRC_URI[sha256sum] = "466410868375d19a286ac3fc5d9f3c267ce359189f8e0d76e72ec10bd54247da"
+
+S = "${WORKDIR}/samba-${PV}/source3"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ samba_cv_linux_getgrouplist_ok=yes \
+ "
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}
+