aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-07 00:38:31 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-08 11:55:55 -0800
commit8cc800b1e9ff93c4579f76a2f1caa2903ae7e0f7 (patch)
tree49ab277635bee52806a2568e524aa618e3b1198e /meta-oe/recipes-connectivity
parent12fe45e84cd43fa913fcb5ad504d40465d7906c6 (diff)
downloadmeta-openembedded-8cc800b1e9ff93c4579f76a2f1caa2903ae7e0f7.tar.gz
iwd: Fix build with ell 0.37
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch31
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.11.bb4
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch
new file mode 100644
index 0000000000..ab55b48b75
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch
@@ -0,0 +1,31 @@
+From 9389f472bc724abb6c6a8db696efb132215783cc Mon Sep 17 00:00:00 2001
+From: Andrew Zaborowski <andrew.zaborowski@intel.com>
+Date: Thu, 24 Dec 2020 00:22:15 +0100
+Subject: [PATCH] crypto: Update l_pkcs5_pbkdf2 call after rename
+
+---
+Upstream-Status: Backport [https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=9ef3d51f8724c9b9f9fd4d4fffcc730f4bb1c806]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ src/crypto.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/crypto.c b/src/crypto.c
+index f5f8e24d..563f17ce 100644
+--- a/src/crypto.c
++++ b/src/crypto.c
+@@ -552,8 +552,9 @@ int crypto_psk_from_passphrase(const char *passphrase,
+ if (ssid_len == 0 || ssid_len > 32)
+ return -ERANGE;
+
+- result = l_pkcs5_pbkdf2(L_CHECKSUM_SHA1, passphrase, ssid, ssid_len,
+- 4096, psk, sizeof(psk));
++ result = l_cert_pkcs5_pbkdf2(L_CHECKSUM_SHA1, passphrase,
++ ssid, ssid_len, 4096,
++ psk, sizeof(psk));
+ if (!result)
+ return -ENOKEY;
+
+--
+2.30.0
+
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.11.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.11.bb
index f4a237e033..2205b72fff 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.11.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.11.bb
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
DEPENDS = "ell"
-SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
+SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
+ file://0001-crypto-Update-l_pkcs5_pbkdf2-call-after-rename.patch \
+ "
SRCREV = "355c2df97e1adfdaee4a67c1705bd76202384687"
S = "${WORKDIR}/git"