aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-14 13:25:43 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-15 12:25:54 -0800
commitf21d8554883e958b96d47fe0cdb9c6e18ff52209 (patch)
tree8c0876732eeb27ae2f24103a5d957f0d03e508af /meta-oe/recipes-connectivity
parenta3015b7b235c06ffca10d2c669d45786b5023af9 (diff)
downloadmeta-openembedded-f21d8554883e958b96d47fe0cdb9c6e18ff52209.tar.gz
librtorrent: Disable instrumentation on rv32
instrumentation code uses atomic ops on 64bit variables, which leads to build failures on 32bit targets using libtorrent because of missing builtins on riscv32/gcc /usr/lib/libtorrent.so: undefined reference to `__sync_add_and_fetch_8' /usr/lib/libtorrent.so: undefined reference to `__sync_fetch_and_and_8' The developer added a "--disable-instrumentation" switch which skips the build of the offending codepaths in libtorrent. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
index 3ee69554b6..e0d3bef3ca 100644
--- a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
@@ -19,6 +19,7 @@ PACKAGECONFIG ??= "instrumentation"
PACKAGECONFIG_remove_mipsarch = "instrumentation"
PACKAGECONFIG_remove_powerpc = "instrumentation"
+PACKAGECONFIG_remove_riscv32 = "instrumentation"
PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"