aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-19 15:20:16 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-19 15:22:26 +0100
commit31acd55435301740b2705e855629184717776ed2 (patch)
tree6f6432adb9e0d6ebe14a06f120a11159e184ecb0 /meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
parentb7259759eecaee335d8af781c7ce3c5b7075ea7d (diff)
downloadmeta-openembedded-31acd55435301740b2705e855629184717776ed2.tar.gz
busybox: update bbappend to match update recipe in oe-core
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend')
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
new file mode 100644
index 0000000000..2c73732400
--- /dev/null
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
@@ -0,0 +1,26 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 3}"
+
+# look for files in the layer first
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://busybox-syslog.service.in \
+ file://busybox-klogd.service.in \
+ file://busybox-syslog.default"
+
+SYSTEMD_PACKAGES = "${PN}-syslog-systemd"
+SYSTEMD_SERVICE_${PN}-syslog-systemd = "busybox-syslog.service"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog
+
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-syslog.service
+ sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \
+ > ${D}${systemd_unitdir}/system/busybox-klogd.service
+
+ ln -sf /dev/null ${D}${systemd_unitdir}/system/syslog.service
+}
+FILES_${PN}-syslog-systemd = "${systemd_unitdir}/system/syslog.service"