aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-19 15:18:21 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-19 15:22:21 +0100
commitaf16bd03d0cd4454e84bce454a3d604da6d08cc8 (patch)
tree2843836027164e565cba6dfa2639fd6dbd455b86 /meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend
parentb0a7f2e761f79e8967b1d3f7c67177283805bf75 (diff)
downloadmeta-openembedded-af16bd03d0cd4454e84bce454a3d604da6d08cc8.tar.gz
dropbear: update bbappend to match update recipe in oe-core
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend')
-rw-r--r--meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend b/meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend
new file mode 100644
index 0000000000..fc5d0476a6
--- /dev/null
+++ b/meta-oe/recipes-core/dropbear/dropbear_2012.55.bbappend
@@ -0,0 +1,17 @@
+inherit systemd
+
+PRINC := "${@int(PRINC) + 2}"
+
+# look for files in the layer first
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+SRC_URI += "file://dropbearkey.service \
+ file://dropbear@.service \
+ file://dropbear.socket"
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE_${PN}-systemd = "dropbear.socket"
+
+do_install_append() {
+ ln -sf /dev/null ${D}${systemd_unitdir}/system/dropbear.service
+}