aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/jpeg
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-13 11:45:31 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-13 11:45:31 +0100
commitb026074a8d03e18790212ac5953c69fb36dbd3bc (patch)
tree555f82cdb52c3ed96c6eac365bf068a03b046253 /meta-oe/recipes-core/jpeg
parent253b1d7bc35c5a2a12dd6a7f2f0c034a34bfae18 (diff)
downloadmeta-openembedded-b026074a8d03e18790212ac5953c69fb36dbd3bc.tar.gz
libjpeg-turbo: initial add
If you're on x86 or ARM this will be a lot faster due to SIMD optimizations Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/jpeg')
-rw-r--r--meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb b/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb
new file mode 100644
index 0000000000..cf1a383d93
--- /dev/null
+++ b/meta-oe/recipes-core/jpeg/libjpeg-turbo_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression"
+HOMEPAGE = "http://libjpeg-turbo.org/"
+
+LICENSE ="BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=12;md5=78fa8dbac547bb5b2a0e6457a6cfe21d \
+ file://jpeglib.h;endline=14;md5=7bb9a39828a1b1e84acd4e8aec1e5532 \
+ file://djpeg.c;endline=13;md5=e85613b52f2906c5dfc0e21ec902cb33 \
+
+PV = "8c+1.2.0"
+SRCREV = "733"
+SRC_URI = "svn://libjpeg-turbo.svn.sourceforge.net/svnroot/libjpeg-turbo;proto=https;module=trunk"
+
+S = "${WORKDIR}/trunk"
+
+# Drop-in replacement for jpeg
+PROVIDES = "jpeg"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-jpeg8 "
+
+PACKAGES =+ "jpeg-tools libturbojpeg"
+
+DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
+FILES_jpeg-tools = "${bindir}/*"
+
+FILES_libturbojpeg = "${libdir}/libturbojpeg.so"
+INSANE_SKIP_libturbojpeg = "dev-so"
+
+BBCLASSEXTEND = "native"