aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-01 13:42:28 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-01 14:33:10 +0100
commit239e817197b287e1a3dc981737543fb9460999e6 (patch)
tree831806baf92382820b935e397bff302209f9df74 /meta-oe/recipes-core/systemd/systemd-compat-units.bb
parentfa226d8c6c7808b5ac6b4aab3349872e090c7e09 (diff)
downloadmeta-openembedded-239e817197b287e1a3dc981737543fb9460999e6.tar.gz
systemd-compat-units: run systemd-machine-id-setup
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-compat-units.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-compat-units.bb b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
index ffcfab22dd..9b60bbc8d6 100644
--- a/meta-oe/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
@@ -3,11 +3,11 @@ DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r12"
+PR = "r14"
inherit allarch
-SRC_URI = "file://opkg.service"
+SRC_URI = "file://*.service"
do_install() {
install -d ${D}${base_libdir}/systemd/system/basic.target.wants
@@ -16,6 +16,10 @@ do_install() {
ln -sf ../opkg.service ${D}${base_libdir}/systemd/system/basic.target.wants/
ln -sf ../opkg.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/
+ install -m 0644 ${WORKDIR}/machineid.service ${D}${base_libdir}/systemd/system
+ ln -sf ../machineid.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/
+ ln -sf ../machineid.service ${D}${base_libdir}/systemd/system/basic.target.wants/
+
# hack to make old style sysvinit postinsts succeed
install -d ${D}${bindir}
echo "echo 1" > ${D}${bindir}/runlevel