aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-19 14:04:16 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-20 08:24:37 +0100
commit6cb51af0e1f09e7658cd1bfdc721cb5106ec9dfd (patch)
treeb0c8fd2d131ac93969fa50de527238a0d467ba52 /meta-oe/recipes-core/systemd
parent3767262f9e626c49638dc886adbdf58b167de61c (diff)
downloadmeta-openembedded-6cb51af0e1f09e7658cd1bfdc721cb5106ec9dfd.tar.gz
systemd: update to v38+git
* This introduces the 'journal' feature. * Upstream is following the fedora /usr move so EXTRA_OECONF needs to get updated to keep the paths the same for the OE usecase Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch36
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch38
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb9
3 files changed, 43 insertions, 40 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch b/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch
deleted file mode 100644
index 24940c780d..0000000000
--- a/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 2649787d76cfe7d89abb1b5afab7cb7cd54b601b Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Sun, 2 Oct 2011 19:54:29 +0200
-Subject: [PATCH] docs: fix build without xsltproc
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
-
-Upstream-status: Pending
-
- Makefile.am | 2 ++
- 2 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index f4a17aa..01240a5 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -750,6 +750,7 @@ EXTRA_DIST += \
- src/dbus-loop.h \
- src/spawn-agent.h
-
-+if HAVE_XSLTPROC
- MANPAGES = \
- man/systemd.1 \
- man/systemctl.1 \
-@@ -844,6 +845,7 @@ EXTRA_DIST += \
- $(XML_IN_FILES) \
- ${nodist_man_MANS:=.in} \
- ${XML_IN_FILES:.xml.in=.html.in}
-+endif
-
- systemd_SOURCES = \
- src/main.c
---
-1.6.6.1
-
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch b/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch
new file mode 100644
index 0000000000..1fec570115
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/0001-docs-fix-build-without-xsltproc.patch
@@ -0,0 +1,38 @@
+From 97719ec99e3bd0040b616b044ab6ae33ae1cfd15 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sun, 2 Oct 2011 19:54:29 +0200
+Subject: [PATCH 1/2] docs: fix build without xsltproc
+
+Make would choke on missing rules for man/systemd.1
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ Makefile.am | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 110a2f4..a5e57b7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -650,6 +650,7 @@ EXTRA_DIST += \
+ src/acl-util.h \
+ src/logs-show.h
+
++if HAVE_XSLTPROC
+ MANPAGES = \
+ man/systemd.1 \
+ man/systemctl.1 \
+@@ -721,6 +722,10 @@ EXTRA_DIST += \
+ $(XML_IN_FILES) \
+ ${nodist_man_MANS:=.in} \
+ ${XML_IN_FILES:.xml.in=.html.in}
++else
++MANPAGES =
++MANPAGES_ALIAS =
++endif
+
+ systemd_SOURCES = \
+ src/main.c
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index bdaaf1659f..32bdee9418 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,14 +14,14 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r7"
+PR = "r8"
inherit useradd pkgconfig autotools vala perlnative
-SRCREV = "f6cebb3bd5a00d79c8131637c0f6796a75e6af99"
+SRCREV = "a3f914b2a21decb0c4bd7a763ddd3ace215091cb"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
- file://0001-disable-xsltproc-completely.patch \
+ file://0001-docs-fix-build-without-xsltproc.patch \
${UCLIBCPATCHES} \
"
UCLIBCPATCHES = ""
@@ -38,7 +38,8 @@ SYSTEMDDISTRO_angstrom = "angstrom"
# The gtk+ tools should get built as a separate recipe e.g. systemd-tools
EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
- --with-rootdir=${base_prefix} \
+ --with-rootprefix=${base_prefix} \
+ --with-rootlibdir=${base_libdir} \
${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
--disable-gtk \
"