aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-22 11:12:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-04-26 13:49:14 +0200
commit7f237b806e38ddfe5c0fdd511a615c75cdaed82e (patch)
tree51ceb23c34c744baee9666b9d00daa57b76da864 /meta-oe/recipes-core/systemd
parent154d0bb399ce6a0bdc2bf756d1a8a9c77dd0a755 (diff)
downloadmeta-openembedded-7f237b806e38ddfe5c0fdd511a615c75cdaed82e.tar.gz
systemd-machine-units: add machine specific recipe for BSPs
* some machines like n900/gta02/palmpre are using extra units to initialize something (g_ether, cmt, ...), so make it easy to bbappend such units * stuff like INHERIT_append_crespo = " systemd" from BSP doesn't play well with systemd.bbclass Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-machine-units_1.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-machine-units_1.0.bb b/meta-oe/recipes-core/systemd/systemd-machine-units_1.0.bb
new file mode 100644
index 0000000000..f223364d43
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd-machine-units_1.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Machine specific systemd units"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit systemd
+SYSTEMD_SERVICE = ""
+SYSTEMD_PACKAGES = "${PN}"
+NATIVE_SYSTEMD_SUPPORT = "1"
+ALLOW_EMPTY_${PN} = "1"