aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-02 20:08:50 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-02 20:08:50 +0200
commitb297ece0b5663aca97d30927a32c20ccce97eb2a (patch)
treebde8baa6ace6638f4e9a21993dbbda12891594b5 /meta-oe/recipes-core/systemd
parentf3d859c4c93a41856e36b858064c12261c004098 (diff)
downloadmeta-openembedded-b297ece0b5663aca97d30927a32c20ccce97eb2a.tar.gz
systemd: update to latest git
Fix docbook-xsl problem by forcing the xsltproc check to false Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch36
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch125
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb12
3 files changed, 42 insertions, 131 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch b/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch
new file mode 100644
index 0000000000..24940c780d
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/0001-disable-xsltproc-completely.patch
@@ -0,0 +1,36 @@
+From 2649787d76cfe7d89abb1b5afab7cb7cd54b601b Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sun, 2 Oct 2011 19:54:29 +0200
+Subject: [PATCH] docs: fix build without xsltproc
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+
+Upstream-status: Pending
+
+ Makefile.am | 2 ++
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f4a17aa..01240a5 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -750,6 +750,7 @@ EXTRA_DIST += \
+ src/dbus-loop.h \
+ src/spawn-agent.h
+
++if HAVE_XSLTPROC
+ MANPAGES = \
+ man/systemd.1 \
+ man/systemctl.1 \
+@@ -844,6 +845,7 @@ EXTRA_DIST += \
+ $(XML_IN_FILES) \
+ ${nodist_man_MANS:=.in} \
+ ${XML_IN_FILES:.xml.in=.html.in}
++endif
+
+ systemd_SOURCES = \
+ src/main.c
+--
+1.6.6.1
+
diff --git a/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch b/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch
deleted file mode 100644
index ef282aab30..0000000000
--- a/meta-oe/recipes-core/systemd/systemd/0003-analyze-draw-kernel-boot-time-as-well.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From 958ae0d75176a65dc6694829667a5cc9fead8cbc Mon Sep 17 00:00:00 2001
-From: Kay Sievers <kay.sievers@vrfy.org>
-Date: Tue, 27 Sep 2011 12:52:09 +0200
-Subject: [PATCH] analyze: always draw top kernel, initramfs, userspace bars
-
-Based on Koen Kooi's patch. Renamed initrd to initramfs.
----
- src/systemd-analyze | 41 ++++++++++++++++++++++++++++++++---------
- 1 files changed, 32 insertions(+), 9 deletions(-)
-
-diff --git a/src/systemd-analyze b/src/systemd-analyze
-index ac64040..729aa05 100755
---- a/src/systemd-analyze
-+++ b/src/systemd-analyze
-@@ -82,7 +82,7 @@ if len(sys.argv) <= 1 or sys.argv[1] == 'time':
- initrd_time, start_time, finish_time = acquire_start_time()
-
- if initrd_time > 0:
-- print "Startup finished in %lums (kernel) + %lums (initrd) + %lums (userspace) = %lums" % ( \
-+ print "Startup finished in %lums (kernel) + %lums (initramfs) + %lums (userspace) = %lums" % ( \
- initrd_time/1000, \
- (start_time - initrd_time)/1000, \
- (finish_time - start_time)/1000, \
-@@ -116,7 +116,11 @@ elif sys.argv[1] == 'plot':
- data = acquire_time_data()
- s = sorted(data, key = lambda i: i[1])
-
-- count = 0
-+ # Account for kernel and initramfs bars if they exist
-+ if initrd_time > 0:
-+ count = 3
-+ else:
-+ count = 2
-
- for name, ixt, aet, axt, iet in s:
-
-@@ -130,7 +134,7 @@ elif sys.argv[1] == 'plot':
- bar_space = bar_height * 0.1
-
- # 1000px = 10s, 1px = 10ms
-- width = (finish_time - start_time)/10000 + border*2
-+ width = finish_time/10000 + border*2
- height = count * (bar_height + bar_space) + border * 2
-
- if width < 1000:
-@@ -147,7 +151,7 @@ elif sys.argv[1] == 'plot':
- context.set_line_width(1)
- context.set_source_rgb(0.7, 0.7, 0.7)
-
-- for x in range(0, max((finish_time - start_time)/10000,110), 100):
-+ for x in range(0, finish_time/10000 + 100, 100):
- context.move_to(x, 0)
- context.line_to(x, height-border*2)
-
-@@ -163,11 +167,30 @@ elif sys.argv[1] == 'plot':
- banner = "Running on %s (%s %s) %s" % (os.uname()[1], os.uname()[2], os.uname()[3], os.uname()[4])
- draw_text(context, 0, -15, banner, hcenter = 0, vcenter = 1)
-
-- for x in range(0, max((finish_time - start_time)/10000,110), 100):
-+ for x in range(0, finish_time/10000 + 100, 100):
- draw_text(context, x, -5, "%lus" % (x/100), vcenter = 0, hcenter = 0)
-
- y = 0
-
-+ # draw boxes for kernel and initramfs boot time
-+ if initrd_time > 0:
-+ draw_box(context, 0, y, initrd_time/10000, bar_height, 0.7, 0.7, 0.7)
-+ draw_text(context, 10, y + bar_height/2, "kernel", hcenter = 0)
-+ y += bar_height + bar_space
-+
-+ draw_box(context, initrd_time/10000, y, start_time/10000-initrd_time/10000, bar_height, 0.7, 0.7, 0.7)
-+ draw_text(context, initrd_time/10000 + 10, y + bar_height/2, "initramfs", hcenter = 0)
-+ y += bar_height + bar_space
-+
-+ else:
-+ draw_box(context, 0, y, start_time/10000, bar_height, 0.6, 0.6, 0.6)
-+ draw_text(context, 10, y + bar_height/2, "kernel", hcenter = 0)
-+ y += bar_height + bar_space
-+
-+ draw_box(context, start_time/10000, y, finish_time/10000-start_time/10000, bar_height, 0.7, 0.7, 0.7)
-+ draw_text(context, start_time/10000 + 10, y + bar_height/2, "userspace", hcenter = 0)
-+ y += bar_height + bar_space
-+
- for name, ixt, aet, axt, iet in s:
-
- drawn = False
-@@ -176,7 +199,7 @@ elif sys.argv[1] == 'plot':
- if ixt >= start_time and ixt <= finish_time:
-
- # Activating
-- a = ixt - start_time
-+ a = ixt
- b = min(filter(lambda x: x >= ixt, (aet, axt, iet, finish_time))) - ixt
-
- draw_box(context, a/10000, y, b/10000, bar_height, 1, 0, 0)
-@@ -188,7 +211,7 @@ elif sys.argv[1] == 'plot':
- if aet >= start_time and aet <= finish_time:
-
- # Active
-- a = aet - start_time
-+ a = aet
- b = min(filter(lambda x: x >= aet, (axt, iet, finish_time))) - aet
-
- draw_box(context, a/10000, y, b/10000, bar_height, .8, .6, .6)
-@@ -200,7 +223,7 @@ elif sys.argv[1] == 'plot':
- if axt >= start_time and axt <= finish_time:
-
- # Deactivating
-- a = axt - start_time
-+ a = axt
- b = min(filter(lambda x: x >= axt, (iet, finish_time))) - axt
-
- draw_box(context, a/10000, y, b/10000, bar_height, .6, .4, .4)
-@@ -222,7 +245,7 @@ elif sys.argv[1] == 'plot':
- draw_text(context, 0, height-border*2, "Legend: Red = Activating; Pink = Active; Dark Pink = Deactivating", hcenter = 0, vcenter = -1)
-
- if initrd_time > 0:
-- draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (initrd) + %lums (userspace) = %lums" % ( \
-+ draw_text(context, 0, height-border*2 + bar_height, "Startup finished in %lums (kernel) + %lums (initramfs) + %lums (userspace) = %lums" % ( \
- initrd_time/1000, \
- (start_time - initrd_time)/1000, \
- (finish_time - start_time)/1000, \
---
-1.6.6.1
-
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index b796411ea5..336fff0707 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
-DEPENDS = "docbook-sgml-dtd-4.1-native gperf-native acl readline udev dbus libcap libcgroup"
+DEPENDS = "docbook-sgml-dtd-4.1-native gperf-native acl readline udev dbus libcap libcgroup tcp-wrappers"
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SERIAL_CONSOLE ?= "115200 /dev/ttyS0"
@@ -14,14 +14,14 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r1"
+PR = "r4"
inherit autotools vala perlnative
-SRCREV = "7c83341a593160e2b4739bdb8a1ad76b21bbdf9e"
+SRCREV = "798e258d301ac237cb1d72b5fc4b19ee900d6f7d"
SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
- file://0003-analyze-draw-kernel-boot-time-as-well.patch \
+ file://0001-disable-xsltproc-completely.patch \
${UCLIBCPATCHES} \
"
UCLIBCPATCHES = ""
@@ -43,9 +43,9 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
--disable-gtk \
"
+# There's no docbook-xsl-native, so for the xsltproc check to false
do_configure_prepend() {
- # avoid network access
- sed -i -e /nonet/d Makefile.am
+ sed -i /xsltproc/d configure.ac
}
do_install() {