aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-22 19:59:38 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-23 07:55:13 +0100
commitc43b2b36bc2f7795f12e8a537e24c65e3c5d4180 (patch)
treed3dc0ff65a98c55365a4e560a4e8f2216868a049 /meta-oe/recipes-core/systemd
parent0658069375e9dfe8c6b5e93b578ca56efaad6512 (diff)
downloadmeta-openembedded-c43b2b36bc2f7795f12e8a537e24c65e3c5d4180.tar.gz
systemd_git: replace ${base_libdir}/systemd by ${systemd_unitdir} set in oe-core
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index a32029911d..e3aec317cf 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -56,10 +56,10 @@ do_configure_prepend() {
do_install() {
autotools_do_install
# provided by a seperate recipe
- rm ${D}${base_libdir}/systemd/system/serial-getty* -f
+ rm ${D}${systemd_unitdir}/system/serial-getty* -f
# provide support for initramfs
- ln -s ${base_libdir}/systemd/systemd ${D}/init
+ ln -s ${systemd_unitdir}/systemd ${D}/init
# create dir for journal
install -d ${D}${localstatedir}/log/journal
@@ -84,9 +84,9 @@ RDEPENDS_${PN}-initramfs = "${PN}"
FILES_${PN}-gui = "${bindir}/systemadm"
-FILES_${PN}-vconsole-setup = "${base_libdir}/systemd/systemd-vconsole-setup \
- ${base_libdir}/systemd/system/systemd-vconsole-setup.service \
- ${base_libdir}/systemd/system/sysinit.target.wants/systemd-vconsole-setup.service"
+FILES_${PN}-vconsole-setup = "${systemd_unitdir}/systemd-vconsole-setup \
+ ${systemd_unitdir}/system/systemd-vconsole-setup.service \
+ ${systemd_unitdir}/system/sysinit.target.wants/systemd-vconsole-setup.service"
RRECOMMENDS_$PN}-vconsole-setup = "kbd kbd-consolefonts"
@@ -96,8 +96,8 @@ FILES_${PN} = " ${base_bindir}/* \
${datadir}/polkit-1 \
${datadir}/${PN} \
${sysconfdir} \
- ${base_libdir}/systemd/* \
- ${base_libdir}/systemd/system/* \
+ ${systemd_unitdir}/* \
+ ${systemd_unitdir}/system/* \
${base_libdir}/udev/rules.d \
${base_libdir}/security/*.so \
/cgroup \
@@ -111,7 +111,7 @@ FILES_${PN} = " ${base_bindir}/* \
${libexecdir} \
"
-FILES_${PN}-dbg += "${base_libdir}/systemd/.debug ${base_libdir}/systemd/*/.debug ${base_libdir}/security/.debug/"
+FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/"
FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/"
RDEPENDS_${PN} += "dbus-systemd udev-systemd"
@@ -135,7 +135,7 @@ RRECOMMENDS_${PN} += "systemd-serialgetty \
# u-a for runlevel and telinit
pkg_postinst_systemd () {
-update-alternatives --install ${base_sbindir}/init init ${base_libdir}/systemd/systemd 300
+update-alternatives --install ${base_sbindir}/init init ${systemd_unitdir}/systemd 300
update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
@@ -143,7 +143,7 @@ update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/s
}
pkg_prerm_systemd () {
-update-alternatives --remove init ${base_libdir}/systemd/systemd
+update-alternatives --remove init ${systemd_unitdir}/systemd
update-alternatives --remove halt ${base_bindir}/systemctl
update-alternatives --remove reboot ${base_bindir}/systemctl
update-alternatives --remove shutdown ${base_bindir}/systemctl