aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-03-09 16:20:15 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-13 18:53:03 +0100
commitc8680dada53e771f0c57ee98f60d4fa6a15a545f (patch)
tree3b443e183e812c9d26faf3708632d23e8f065ce9 /meta-oe/recipes-core/systemd
parentae522fe36a87f40612f21ac4394e05d674a16745 (diff)
downloadmeta-openembedded-c8680dada53e771f0c57ee98f60d4fa6a15a545f.tar.gz
systemd-compat-units: rename service to run postinst scripts
OE-Core uses run-postinsts script to trigger package configuration on first boot so the service ought to be named the same, for consistency. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd-compat-units.bb8
-rw-r--r--meta-oe/recipes-core/systemd/systemd-compat-units/run-postinsts.service (renamed from meta-oe/recipes-core/systemd/systemd-compat-units/opkg.service)6
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-compat-units.bb b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
index 9b60bbc8d6..2cbce67d6d 100644
--- a/meta-oe/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta-oe/recipes-core/systemd/systemd-compat-units.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r14"
+PR = "r15"
inherit allarch
@@ -12,9 +12,9 @@ SRC_URI = "file://*.service"
do_install() {
install -d ${D}${base_libdir}/systemd/system/basic.target.wants
install -d ${D}${base_libdir}/systemd/system/sysinit.target.wants/
- install -m 0644 ${WORKDIR}/opkg.service ${D}${base_libdir}/systemd/system
- ln -sf ../opkg.service ${D}${base_libdir}/systemd/system/basic.target.wants/
- ln -sf ../opkg.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/
+ install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${base_libdir}/systemd/system
+ ln -sf ../run-postinsts.service ${D}${base_libdir}/systemd/system/basic.target.wants/
+ ln -sf ../run-postinsts.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/
install -m 0644 ${WORKDIR}/machineid.service ${D}${base_libdir}/systemd/system
ln -sf ../machineid.service ${D}${base_libdir}/systemd/system/sysinit.target.wants/
diff --git a/meta-oe/recipes-core/systemd/systemd-compat-units/opkg.service b/meta-oe/recipes-core/systemd/systemd-compat-units/run-postinsts.service
index 36cedf22b1..879a25157b 100644
--- a/meta-oe/recipes-core/systemd/systemd-compat-units/opkg.service
+++ b/meta-oe/recipes-core/systemd/systemd-compat-units/run-postinsts.service
@@ -1,12 +1,12 @@
[Unit]
-Description=Opkg first boot configure
+Description=Run pending postinsts
DefaultDependencies=no
-ConditionPathExists=|/etc/rcS.d/S98configure
+ConditionPathExists=|/etc/rcS.d/S98run-postinsts
After=remount-rootfs.service
Before=sysinit.target
[Service]
-ExecStart=/etc/rcS.d/S98configure
+ExecStart=/etc/rcS.d/S98run-postinsts
RemainAfterExit=No
Type=oneshot
StandardOutput=syslog