aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-10-21 13:55:53 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:23:42 +0200
commit48e381fcb09f2c91318e53f9256f4f702a046b9a (patch)
treeb41e55f37eda7c5f5fc3c86480e1aa44332c6c77 /meta-oe/recipes-core/systemd
parent7a364f8abc8090f662c7dccc21a7f389e54369f3 (diff)
downloadmeta-openembedded-48e381fcb09f2c91318e53f9256f4f702a046b9a.tar.gz
systemd: add lock group using useradd.bbclass
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb15
1 files changed, 5 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index c5503e8409..4d314f85ee 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,9 +14,9 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r2"
+PR = "r3"
-inherit pkgconfig autotools vala perlnative
+inherit useradd pkgconfig autotools vala perlnative
SRCREV = "64685e0cea62b4937f0804e47ce2cb7929f58223"
@@ -59,6 +59,9 @@ do_install() {
PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs"
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "-r lock"
+
FILES_${PN}-initramfs = "/init"
RDEPENDS_${PN}-initramfs = "${PN}"
@@ -113,12 +116,4 @@ update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl
update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
-
-# can't do this offline, but we need the u-a bits above
-if [ "x$D" != "x" ]; then
- echo "can't do addgroup offline" ; exit 1
-else
- grep "^lock:" /etc/group > /dev/null || addgroup lock
-fi
}
-