aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2012-01-19 19:53:07 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-20 08:24:37 +0100
commitacfe5820feacb045751e8f9c63cb020427fcfd35 (patch)
tree804ea9b179f5caa9b929c00a4f6c3ac0770b1687 /meta-oe/recipes-core/systemd
parent6cb51af0e1f09e7658cd1bfdc721cb5106ec9dfd (diff)
downloadmeta-openembedded-acfe5820feacb045751e8f9c63cb020427fcfd35.tar.gz
systemd: split out systemd-analyze
Split systemd-analyze to a separate package, to remove the implicit dependency on python. (At least the rpm-packaging backend created a run-time dependency on python). Add an RDEPENDS_${PN}-analyze on python-dbus, as this is required for systemd-analyze to work. Add an RRECOMMENDS_${PN}-analyze on python-pycairo, as the plot command in systemd-analyze requires this package. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 32bdee9418..b779f61d95 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r8"
+PR = "r9"
inherit useradd pkgconfig autotools vala perlnative
@@ -58,11 +58,15 @@ do_install() {
ln -s ${base_bindir}/systemd ${D}/init
}
-PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs"
+PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze"
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "-r lock"
+FILES_${PN}-analyze = "${bindir}/systemd-analyze"
+RDEPENDS_${PN}-analyze = "python-dbus"
+RRECOMMENDS_${PN}-analyze = "python-pycairo"
+
FILES_${PN}-initramfs = "/init"
RDEPENDS_${PN}-initramfs = "${PN}"