aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/systemd
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-10-21 13:55:52 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-21 16:13:47 +0200
commitca82bc073d164fd49f3b3b830545e879096abc5c (patch)
treea32df8e5f68c1d5b7c7cc1c1484f08fe13e8cb04 /meta-oe/recipes-core/systemd
parent8fee9e2af657f1233ceda5f0fd8dab76554d03be (diff)
downloadmeta-openembedded-ca82bc073d164fd49f3b3b830545e879096abc5c.tar.gz
systemd: add systemd-initramfs
Includes a /init that points to ${base_sbin}/init that is called so to avoid having to include post rootfs commands for it. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 8faedd03fe..f9e024bd1d 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r0"
+PR = "r1"
inherit pkgconfig autotools vala perlnative
@@ -52,9 +52,15 @@ do_install() {
autotools_do_install
# provided by a seperate recipe
rm ${D}${base_libdir}/systemd/system/serial-getty* -f
+
+ # provide support for initramfs
+ ln -s ${base_sbindir}/init ${D}/systemd
}
-PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup"
+PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs"
+
+FILES_${PN}-initramfs = "/init"
+RDEPENDS_${PN}-initramfs = "${PN}"
FILES_${PN}-gui = "${bindir}/systemadm"