aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/tasks
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-10-29 10:19:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-11-01 09:57:03 +0100
commit8f79297046d8bda340ebf00d004d44288dae93ee (patch)
tree453efbc0c0d981cf2d788a10b1dab9e9ecee9a29 /meta-oe/recipes-core/tasks
parent776cb915ff4123a55eb1a03fa11c705339118da3 (diff)
downloadmeta-openembedded-8f79297046d8bda340ebf00d004d44288dae93ee.tar.gz
task-x11: remove server parts and add VIRTUAL_RUNTIME variables to be able to select different -common and init providers
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/tasks')
-rw-r--r--meta-oe/recipes-core/tasks/task-x11.bb41
-rw-r--r--meta-oe/recipes-core/tasks/task-x11_1.0.bb30
2 files changed, 30 insertions, 41 deletions
diff --git a/meta-oe/recipes-core/tasks/task-x11.bb b/meta-oe/recipes-core/tasks/task-x11.bb
deleted file mode 100644
index a7faa00a09..0000000000
--- a/meta-oe/recipes-core/tasks/task-x11.bb
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
-SECTION = "x11/server"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PV = "1.0"
-PR = "r8"
-
-# WORK IN PROGRESS
-
-inherit task
-
-PACKAGES += "\
- ${PN}-server \
- ${PN}-utils \
-"
-
-RRECOMMENDS_${PN} = "\
- ${PN}-server \
- ${PN}-utils \
-"
-
-# Some machines don't set a *runtime* provider for X, so default to Xfbdev here
-# virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
-XSERVER ?= "xserver-xorg"
-XSERVER_COMMON ?= "xserver-common"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-RDEPENDS_${PN}-server = "\
- ${XSERVER} \
-"
-
-RDEPENDS_${PN}-utils = "\
- ${XSERVER_COMMON} \
- xserver-nodm-init \
- xauth \
- xhost \
- xset \
- xrandr \
-"
-
diff --git a/meta-oe/recipes-core/tasks/task-x11_1.0.bb b/meta-oe/recipes-core/tasks/task-x11_1.0.bb
new file mode 100644
index 0000000000..67ff93b1f4
--- /dev/null
+++ b/meta-oe/recipes-core/tasks/task-x11_1.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
+SECTION = "x11/server"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r9"
+
+inherit task
+
+PACKAGES += "${PN}-utils"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-server \
+ ${PN}-utils \
+"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "xserver-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+RDEPENDS_${PN}-utils = "\
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+"
+