aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/tasks
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-20 07:28:44 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-20 07:28:44 +0200
commit959d90a32409231e3e121277c64ff7839f1d815e (patch)
tree59c68708a9d4c4cf35051947ec187b4af2aec4ec /meta-oe/recipes-core/tasks
parent3beeb8b355feaa239a214d0f93a2a00b4933a0f3 (diff)
downloadmeta-openembedded-959d90a32409231e3e121277c64ff7839f1d815e.tar.gz
task-basic: include MACHINE_EXTRA_RRECOMMENDS
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/tasks')
-rw-r--r--meta-oe/recipes-core/tasks/task-basic.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/tasks/task-basic.bb b/meta-oe/recipes-core/tasks/task-basic.bb
index 4da66efd09..ffb7f12fe9 100644
--- a/meta-oe/recipes-core/tasks/task-basic.bb
+++ b/meta-oe/recipes-core/tasks/task-basic.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Basic task to get a device online"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r1"
+PR = "r2"
inherit task
@@ -13,6 +13,10 @@ inherit task
#
PACKAGE_ARCH = "${MACHINE_ARCH}"
+# Poke extra recomendations into the list using your machine.conf
+#
+MACHINE_EXTRA_RRECOMMENDS ?= ""
+
#
# Select between dropbear and openssh
# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp" in your DISTRO config to get openssh(d)
@@ -41,6 +45,7 @@ RDEPENDS_${PN} = "\
# 3) Nice to have: packages that are nice to have, but aren't strictly needed
#
RRECOMMENDS_${PN} = "\
+ ${MACHINE_EXTRA_RRECOMMENDS} \
${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \