aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/tasks
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-14 19:00:14 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-14 19:00:14 +0200
commitb7d2870311fe4f7473aa812f2bd66bd1a72d10fd (patch)
tree2eb10bdf25ff2c977bb1a8cf3a2ef7791ee3ea75 /meta-oe/recipes-core/tasks
parent71f54a8d0a2d0b7164022d8dab6ada674a40104e (diff)
downloadmeta-openembedded-b7d2870311fe4f7473aa812f2bd66bd1a72d10fd.tar.gz
task-basic: include util-linux-(u)mount, the busybox ones are broken, broken, broken
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/tasks')
-rw-r--r--meta-oe/recipes-core/tasks/task-basic.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/tasks/task-basic.bb b/meta-oe/recipes-core/tasks/task-basic.bb
index 9e8ae979f6..4da66efd09 100644
--- a/meta-oe/recipes-core/tasks/task-basic.bb
+++ b/meta-oe/recipes-core/tasks/task-basic.bb
@@ -5,6 +5,8 @@ DESCRIPTION = "Basic task to get a device online"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+PR = "r1"
+
inherit task
# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
@@ -23,11 +25,14 @@ TASK_BASIC_SSHDAEMON ?= "dropbear-systemd openssh-sftp"
# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
# distro feature.
#
+# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
+#
RDEPENDS_${PN} = "\
- ${TASK_BASIC_SSHDAEMON} \
- avahi-daemon avahi-utils avahi-systemd \
- systemd-compat-units \
- "
+ ${TASK_BASIC_SSHDAEMON} \
+ avahi-daemon avahi-utils avahi-systemd \
+ systemd-compat-units \
+ util-linux-mount util-linux-umount \
+ "
#
# The following section is split in 3: