aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/tasks
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-01-16 11:50:47 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-16 11:53:39 +0100
commitcac1ca451a303cf4e234629fed0588fdbd669c69 (patch)
treefeebcdb60a49f84faf1867789fb9530e451054ea /meta-oe/recipes-core/tasks
parenta5eae966b971c2fd34356df324dcef2d7eb37c7f (diff)
downloadmeta-openembedded-cac1ca451a303cf4e234629fed0588fdbd669c69.tar.gz
task-boot: leave packagemanagement decisions to image recipes
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/tasks')
-rw-r--r--meta-oe/recipes-core/tasks/task-boot.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta-oe/recipes-core/tasks/task-boot.bb b/meta-oe/recipes-core/tasks/task-boot.bb
index d461888926..6c27ffe445 100644
--- a/meta-oe/recipes-core/tasks/task-boot.bb
+++ b/meta-oe/recipes-core/tasks/task-boot.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Basic task to get a device booting"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r56"
+PR = "r57"
inherit task
@@ -16,12 +16,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
-# update-alternatives script installed in rootfs needs to be the same as
-# u-a script used for building image which is defined with
-# PREFERRED_PROVIDER_virtual/update-alternatives-native
-
-DISTRO_UPDATE_ALTERNATIVES ?= "${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${PREFERRED_PROVIDER_virtual/update-alternatives}", d)}"
-
# Make sure we build the kernel
DEPENDS = "virtual/kernel"
@@ -34,7 +28,6 @@ RDEPENDS_${PN} = "\
busybox \
netbase \
${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
- ${DISTRO_UPDATE_ALTERNATIVES} \
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
"