aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/toybox
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-core/toybox
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-core/toybox')
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.7.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
index defca7016f..032b138552 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
@@ -59,8 +59,8 @@ python do_package_prepend () {
# Read links from /etc/toybox.links and create appropriate
# update-alternatives variables
- dvar = d.getVar('D', True)
- pn = d.getVar('PN', True)
+ dvar = d.getVar('D')
+ pn = d.getVar('PN')
target = "/bin/toybox"
f = open('%s/etc/toybox.links' % (dvar), 'r')