aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-08-07 09:48:44 +0200
committerEric Bénard <eric@eukrea.com>2012-08-13 10:39:20 +0200
commita4c4a48148368c884dbc57d50195af3806c4aa37 (patch)
tree23c24bc5a539b211b56765319f23d3743194f6e7 /meta-oe/recipes-core
parent369bd8bdda774c660756001835737104833389fe (diff)
downloadmeta-openembedded-a4c4a48148368c884dbc57d50195af3806c4aa37.tar.gz
systemd: cleanup /var/run on boot and create /var/run/utmp
* Angstrom uses /var/run cleanup because: Some apps (e.g. avahi-daemon) to clean up their old-style pid files and fail to start every other boot. Se we let systemd clean it on boot. Which seems general enough, so lets move var-run.conf from base-files.bbappend to systemd recipe. * /var/run/utmp was created by volatiles before, but without sysvinit installed systemd-update-utmp-runlevel.service fails to start without this file Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/var-run.conf4
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb5
2 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/var-run.conf b/meta-oe/recipes-core/systemd/systemd/var-run.conf
new file mode 100644
index 0000000000..c2c18e2b99
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/var-run.conf
@@ -0,0 +1,4 @@
+# empty /var/run
+R /var/run/* - - - - -
+# systemd-update-utmp-runlevel.service fails to start without this
+f /var/run/utmp 0644 root root - -
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index f4ca72a128..b9c8a190cf 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,7 +14,7 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r27"
+PR = "r28"
inherit useradd pkgconfig autotools vala perlnative
@@ -22,6 +22,7 @@ SRCREV = "3eff4208ffecedd778fec260f0d4b18e94dab443"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
${UCLIBCPATCHES} \
+ file://var-run.conf \
"
UCLIBCPATCHES = ""
UCLIBCPATCHES_libc-uclibc = "file://paper-over-mkostemp.patch \
@@ -68,6 +69,8 @@ do_install() {
# create machine-id
# 20:12 < mezcalero> koen: you have three options: a) run systemd-machine-id-setup at install time, b) have / read-only and an empty file there (for stateless) and c) boot with / writable
touch ${D}${sysconfdir}/machine-id
+
+ install -m 0644 ${WORKDIR}/var-run.conf ${D}${sysconfdir}/tmpfiles.d/
}
python populate_packages_prepend (){