aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-30 23:57:11 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-01 11:24:26 -0800
commit10039570ec4d54b66d3fe70866758b0b0d94c07f (patch)
tree5bf8548c95aa3d1211659745d4bd3dd0fa9e344a /meta-oe/recipes-core
parent310047ec9f2667ae1a98a55aa14edb87cd1e1e6c (diff)
downloadmeta-openembedded-10039570ec4d54b66d3fe70866758b0b0d94c07f.tar.gz
kernel-module-emlog: Use compile task from module bbclass
This ensures that right CC/LD is used when building the module, which should be KERNEL_CC and KERNEL_LD, otherwise it starts to use DISTRO default ld and cc which could be non-gcc and non-bfd liker which is must for building kernel and modules Also hides a gold linker failure seen on aarch64 | aarch64-yoe-linux-musl-ld: internal error in set_address, at ../../gold/output.h:322 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/emlog/kernel-module-emlog_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/emlog/kernel-module-emlog_git.bb b/meta-oe/recipes-core/emlog/kernel-module-emlog_git.bb
index 51f7226ebd..a554a4c947 100644
--- a/meta-oe/recipes-core/emlog/kernel-module-emlog_git.bb
+++ b/meta-oe/recipes-core/emlog/kernel-module-emlog_git.bb
@@ -7,6 +7,4 @@ EXTRA_OEMAKE += " \
KVER=${KERNEL_VERSION} \
"
-do_compile() {
- oe_runmake modules
-}
+MAKE_TARGETS = "modules"