aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-27 12:57:15 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-27 21:57:32 +0200
commit83aaa60d4934a70084a846a0e6d240c09dbc66a9 (patch)
tree1b61287b26cf1cd02893bb05348419fd5744ef4f /meta-oe/recipes-core
parent5a3d0de38a3af92d07503184fb214df6e9f57610 (diff)
downloadmeta-openembedded-83aaa60d4934a70084a846a0e6d240c09dbc66a9.tar.gz
busybox 1.19.4 bbapped: create dir before installing into it, fixes build failures on the autobuilder
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
index 2c73732400..786e1d52d5 100644
--- a/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
+++ b/meta-oe/recipes-core/busybox/busybox_1.19.4.bbappend
@@ -1,6 +1,6 @@
inherit systemd
-PRINC := "${@int(PRINC) + 3}"
+PRINC := "${@int(PRINC) + 4}"
# look for files in the layer first
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -16,6 +16,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog
+ install -d ${D}${systemd_unitdir}/system
sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-syslog.service.in \
> ${D}${systemd_unitdir}/system/busybox-syslog.service
sed 's,@base_sbindir@,${base_sbindir},g' < ${WORKDIR}/busybox-klogd.service.in \