aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-03-18 09:37:06 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-18 13:04:15 +0100
commitb0a7f2e761f79e8967b1d3f7c67177283805bf75 (patch)
treea2dcf70b9ee2c36621325b2b4fc85efb69b91c3d /meta-oe/recipes-core
parent85be934bdcf0ffb4dabdfb4fad06277dfd473c4e (diff)
downloadmeta-openembedded-b0a7f2e761f79e8967b1d3f7c67177283805bf75.tar.gz
systemd: update to v44 + CVE fix
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd/0001-Revert-journald-allocate-PAGE_SIZE-bytes-for-selinux.patch34
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb5
2 files changed, 37 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd/0001-Revert-journald-allocate-PAGE_SIZE-bytes-for-selinux.patch b/meta-oe/recipes-core/systemd/systemd/0001-Revert-journald-allocate-PAGE_SIZE-bytes-for-selinux.patch
new file mode 100644
index 0000000000..9c74f67c20
--- /dev/null
+++ b/meta-oe/recipes-core/systemd/systemd/0001-Revert-journald-allocate-PAGE_SIZE-bytes-for-selinux.patch
@@ -0,0 +1,34 @@
+From 9d3226c3a3dd34e7299aa693544e45b8ebe9410b Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Sun, 18 Mar 2012 09:18:39 +0100
+Subject: [PATCH] Revert "journald: allocate PAGE_SIZE bytes for selinux label length"
+
+This reverts commit 2d44fc7ba5aaf700672baa7b0697caefddafdc53.
+---
+ src/journal/journald.c | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/src/journal/journald.c b/src/journal/journald.c
+index baad3ab..3dde891 100644
+--- a/src/journal/journald.c
++++ b/src/journal/journald.c
+@@ -29,7 +29,6 @@
+ #include <sys/ioctl.h>
+ #include <linux/sockios.h>
+ #include <sys/statvfs.h>
+-#include <sys/user.h>
+
+ #include <systemd/sd-journal.h>
+ #include <systemd/sd-login.h>
+@@ -2144,7 +2143,7 @@ static int process_event(Server *s, struct epoll_event *ev) {
+ uint8_t buf[CMSG_SPACE(sizeof(struct ucred)) +
+ CMSG_SPACE(sizeof(struct timeval)) +
+ CMSG_SPACE(sizeof(int)) +
+- CMSG_SPACE(PAGE_SIZE)]; /* selinux label */
++ CMSG_SPACE(LINE_MAX)]; /* selinux label */
+ } control;
+ ssize_t n;
+ int v;
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index e99be88f8d..a32029911d 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,13 +14,14 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r22"
+PR = "r23"
inherit useradd pkgconfig autotools vala perlnative
-SRCREV = "03f38e74984d93aa83c056893d414a5e3eac5763"
+SRCREV = "5ebff5337594d690b322078c512eb222d34aaa82"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
+ file://0001-Revert-journald-allocate-PAGE_SIZE-bytes-for-selinux.patch \
file://0002-systemd-logind-don-t-kill-user-processes-on-exit.patch \
${UCLIBCPATCHES} \
"