aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2019-06-17 01:41:51 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-17 08:17:12 -0700
commit52a326728a0682bd2a28a133b9f112e951acf372 (patch)
tree545d541369ccc13008dd1d0173ce5d52263d7acb /meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb
parente49a68fa658213df8b5ff4b6d51ba630323af95b (diff)
downloadmeta-openembedded-52a326728a0682bd2a28a133b9f112e951acf372.tar.gz
mariadb: Upgrade to 10.3.16
License-Update: The address of Free Software Foundation updated Bug fixes: MDEV-19490: show tables fails when selecting the information_schema database MDEV-19541: InnoDB crashes when trying to recover a corrupted page More details check: https://jira.mariadb.org/browse/MDEV-19490 https://jira.mariadb.org/browse/MDEV-19541 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb')
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb b/meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb
new file mode 100644
index 0000000000..e1a038dfa3
--- /dev/null
+++ b/meta-oe/recipes-dbs/mysql/mariadb-native_10.3.16.bb
@@ -0,0 +1,20 @@
+require mariadb.inc
+inherit native
+
+PROVIDES += "mysql5-native"
+DEPENDS = "ncurses-native zlib-native bison-native"
+
+RDEPENDS_${PN} = ""
+PACKAGES = ""
+EXTRA_OEMAKE = ""
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+
+ install -d ${D}${bindir}
+ install -m 0755 sql/gen_lex_hash ${D}${bindir}/
+ install -m 0755 sql/gen_lex_token ${D}${bindir}/
+ install -m 0755 extra/comp_err ${D}${bindir}/
+ install -m 0755 scripts/comp_sql ${D}${bindir}/
+}
+