aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2022-05-26 15:13:47 -0700
committerArmin Kuster <akuster808@gmail.com>2022-06-05 06:53:33 -0700
commit04212afa12e4bcd1a0a80dfa08c345f0f1ddd314 (patch)
tree69bcef86f2e4e8ab0d62b71a9d03e1304950cd65 /meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb
parentdeee226017877d51188e0a46f9e6b93c10ffbb34 (diff)
downloadmeta-openembedded-04212afa12e4bcd1a0a80dfa08c345f0f1ddd314.tar.gz
mariadb: update to 10.4.25
Source: mariadb.org MR: 117530, 117522, 117514, 117506, 117497, 117489, 117481, 117473, 117465, 117457, 117449, 117380, 117364, 117356, 117336, 117212, 117204, 117196, 117180, 117188, 117169, 117161, 117441, 117372 Type: Security Fix Disposition: Backport from mariagdb.org ChangeID: 8bf787570ebe8503d2974af92e17b505e70440e5 Description: LTS version, bug fix only. Include these CVES: CVE-2022-27458 CVE-2022-27457 CVE-2022-27456 CVE-2022-27455 CVE-2022-27452 CVE-2022-27451 CVE-2022-27449 CVE-2022-27448 CVE-2022-27447 CVE-2022-27446 CVE-2022-27445 CVE-2022-27444 CVE-2022-27387 CVE-2022-27386 CVE-2022-27385 CVE-2022-27384 CVE-2022-27383 CVE-2022-27382 CVE-2022-27381 CVE-2022-27380 CVE-2022-27379 CVE-2022-27378 CVE-2022-27377 CVE-2022-27376 Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb')
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb b/meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb
new file mode 100644
index 0000000000..e1a038dfa3
--- /dev/null
+++ b/meta-oe/recipes-dbs/mysql/mariadb-native_10.4.25.bb
@@ -0,0 +1,20 @@
+require mariadb.inc
+inherit native
+
+PROVIDES += "mysql5-native"
+DEPENDS = "ncurses-native zlib-native bison-native"
+
+RDEPENDS_${PN} = ""
+PACKAGES = ""
+EXTRA_OEMAKE = ""
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+
+ install -d ${D}${bindir}
+ install -m 0755 sql/gen_lex_hash ${D}${bindir}/
+ install -m 0755 sql/gen_lex_token ${D}${bindir}/
+ install -m 0755 extra/comp_err ${D}${bindir}/
+ install -m 0755 scripts/comp_sql ${D}${bindir}/
+}
+