aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/postgresql/files
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-06-04 15:31:04 +0800
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit6a160e340db2df76c5f55567da27021c8af8c1e3 (patch)
tree2ae2c4ffe27483e2dec6b20654d3205e7e0fac92 /meta-oe/recipes-dbs/postgresql/files
parent5d1e72d9f79cb8b064dad6baf50bb2ca33d2ce32 (diff)
downloadmeta-openembedded-6a160e340db2df76c5f55567da27021c8af8c1e3.tar.gz
postgresql: improve reproducibility
- Make pg_config not record var-CC, var-CFLAGS, and configure which contains build paths - Split pgxs in which Makefile.global contains build path from package postgresql to postgresql-server-dev, it refers ubuntu Here is we got from Ubuntu 18.04 $ dpkg -c /var/cache/apt/archives/postgresql-server-dev-10_10.8-0ubuntu0.18.04.1_amd64.deb -rwxr-xr-x root/root 30792 2019-05-07 17:20 ./usr/lib/postgresql/10/bin/pg_config drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/config/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/src/ -rw-r--r-- root/root 31309 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/src/Makefile.global Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/postgresql/files')
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch b/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
new file mode 100644
index 0000000000..32b7f42845
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
@@ -0,0 +1,39 @@
+From 3c13315447fa175da6c9ebe59a039e611cdb5bd1 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 4 Jun 2019 13:45:30 +0800
+Subject: [PATCH] Improve reproducibility,
+
+Remove build patch from binaries which pg_config do
+not record var-CC, var-CFLAGS, and configure
+
+$ /usr/bin/pg_config --cc
+not recorded
+
+$ /usr/bin/pg_config --configure
+not recorded
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ src/common/Makefile | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/common/Makefile b/src/common/Makefile
+index 1fc2c66..5e6c457 100644
+--- a/src/common/Makefile
++++ b/src/common/Makefile
+@@ -27,10 +27,6 @@ include $(top_builddir)/src/Makefile.global
+ # don't include subdirectory-path-dependent -I and -L switches
+ STD_CPPFLAGS := $(filter-out -I$(top_srcdir)/src/include -I$(top_builddir)/src/include,$(CPPFLAGS))
+ STD_LDFLAGS := $(filter-out -L$(top_builddir)/src/common -L$(top_builddir)/src/port,$(LDFLAGS))
+-override CPPFLAGS += -DVAL_CONFIGURE="\"$(configure_args)\""
+-override CPPFLAGS += -DVAL_CC="\"$(CC)\""
+-override CPPFLAGS += -DVAL_CPPFLAGS="\"$(STD_CPPFLAGS)\""
+-override CPPFLAGS += -DVAL_CFLAGS="\"$(CFLAGS)\""
+ override CPPFLAGS += -DVAL_CFLAGS_SL="\"$(CFLAGS_SL)\""
+ override CPPFLAGS += -DVAL_LDFLAGS="\"$(STD_LDFLAGS)\""
+ override CPPFLAGS += -DVAL_LDFLAGS_EX="\"$(LDFLAGS_EX)\""
+--
+2.7.4
+