aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/postgresql
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-02-24 09:38:11 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:38 -0800
commit742404cc8ab08316b0c02310c89958972d43d22e (patch)
tree0fbbb80e1716548f3fe2b9d8383f9da8ad707abc /meta-oe/recipes-dbs/postgresql
parenteaff8c24ab1b88efc9340d90c268f4aea3795992 (diff)
downloadmeta-openembedded-742404cc8ab08316b0c02310c89958972d43d22e.tar.gz
postgres: move to recipes-dbs
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/postgresql')
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch43
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch31
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/postgresql-bashprofile4
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/postgresql-setup73
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/postgresql.init193
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/postgresql.pam4
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/postgresql.service27
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/remove.autoconf.version.check.patch16
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc383
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_9.4.15.bb15
10 files changed, 789 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch b/meta-oe/recipes-dbs/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch
new file mode 100644
index 0000000000..d08ec6af1d
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/0001-Use-pkg-config-for-libxml2-detection.patch
@@ -0,0 +1,43 @@
+From d52e330be895bb8c5f0fb3e2884766acbd942a85 Mon Sep 17 00:00:00 2001
+From: Philip Balister <philip@balister.org>
+Date: Tue, 1 Jul 2014 09:40:44 -0400
+Subject: [PATCH] Use pkg-config for libxml2 detection.
+
+Upstream-Status: Inappropriate [configuration]
+
+xml2-config does not work. Use pkgconfig to set CPPFLAGS and LIBS.
+
+Signed-off-by: Philip Balister <philip@balister.org>
+---
+ configure.in | 15 ++-------------
+ 1 file changed, 2 insertions(+), 13 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index f8bf466..1f4fabf 100644
+--- a/configure.in
++++ b/configure.in
+@@ -734,19 +734,8 @@ PGAC_ARG_BOOL(with, libxml, no, [build with XML support],
+ [AC_DEFINE([USE_LIBXML], 1, [Define to 1 to build with XML support. (--with-libxml)])])
+
+ if test "$with_libxml" = yes ; then
+- AC_CHECK_PROGS(XML2_CONFIG, xml2-config)
+- if test -n "$XML2_CONFIG"; then
+- for pgac_option in `$XML2_CONFIG --cflags`; do
+- case $pgac_option in
+- -I*|-D*) CPPFLAGS="$CPPFLAGS $pgac_option";;
+- esac
+- done
+- for pgac_option in `$XML2_CONFIG --libs`; do
+- case $pgac_option in
+- -L*) LDFLAGS="$LDFLAGS $pgac_option";;
+- esac
+- done
+- fi
++ CPPFLAGS="$CPPFLAGS `pkg-config --short-errors --print-errors --cflags "libxml-2.0" 2>&1`"
++ LIBS="`pkg-config --short-errors --print-errors --libs "libxml-2.0" 2>&1` $LIBS"
+ fi
+
+ AC_SUBST(with_libxml)
+--
+1.8.3.1
+
diff --git a/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch b/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch
new file mode 100644
index 0000000000..e199f39143
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/not-check-libperl.patch
@@ -0,0 +1,31 @@
+[PATCH] not check libperl under cross compiling
+
+Upstream-Status: Inappropriate [configuration]
+
+libperl ldflags returned by PGAC_CHECK_PERL_EMBED_LDFLAGS are native,
+can not be used to check target library.
+
+postpresql has the dependency on perl, so not need to check libperl
+again, like in postgresql-9.2.4
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index ae1a5a0..9a0970d 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1877,7 +1877,7 @@ if test "$with_tcl" = yes; then
+ fi
+
+ # check for <perl.h>
+-if test "$with_perl" = yes; then
++if test "$with_perl" = yes && test "$cross_compiling" = no; then
+ ac_save_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -I$perl_archlibexp/CORE"
+ AC_CHECK_HEADER(perl.h, [], [AC_MSG_ERROR([header file <perl.h> is required for Perl])],
+--
+1.9.1
+
diff --git a/meta-oe/recipes-dbs/postgresql/files/postgresql-bashprofile b/meta-oe/recipes-dbs/postgresql/files/postgresql-bashprofile
new file mode 100644
index 0000000000..1c931f37fd
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/postgresql-bashprofile
@@ -0,0 +1,4 @@
+[ -f /etc/profile ] && source /etc/profile
+
+PGDATA=/var/lib/postgresql/data
+export PGDATA
diff --git a/meta-oe/recipes-dbs/postgresql/files/postgresql-setup b/meta-oe/recipes-dbs/postgresql/files/postgresql-setup
new file mode 100644
index 0000000000..75bb01e05f
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/postgresql-setup
@@ -0,0 +1,73 @@
+#!/bin/sh
+#
+# postgresql-setup Initialization operation for PostgreSQL
+
+# For SELinux we need to use 'runuser' not 'su'
+if [ -x /sbin/runuser ]
+then
+ SU=runuser
+else
+ SU=su
+fi
+
+PGENGINE=/usr/bin
+PGDATA=/var/lib/postgresql/data
+PGLOG=/var/lib/postgresql/pgstartup.log
+script_result=0
+
+initdb(){
+ if [ -f "$PGDATA/PG_VERSION" ]
+ then
+ echo -n "Data directory is not empty!"
+ echo -n " [FAILED] "
+ echo
+ script_result=1
+ else
+ echo -n "Initializing database: "
+ if [ ! -e "$PGDATA" -a ! -h "$PGDATA" ]
+ then
+ mkdir -p "$PGDATA" || exit 1
+ chown postgres:postgres "$PGDATA"
+ chmod go-rwx "$PGDATA"
+ fi
+ # Clean up SELinux tagging for PGDATA
+ [ -x /sbin/restorecon ] && /sbin/restorecon "$PGDATA"
+
+ # Make sure the startup-time log file is OK, too
+ if [ ! -e "$PGLOG" -a ! -h "$PGLOG" ]
+ then
+ touch "$PGLOG" || exit 1
+ chown postgres:postgres "$PGLOG"
+ chmod go-rwx "$PGLOG"
+ [ -x /sbin/restorecon ] && /sbin/restorecon "$PGLOG"
+ fi
+
+ # Initialize the database
+ $SU -l postgres -c "$PGENGINE/initdb --pgdata='$PGDATA' --auth='ident'" >> "$PGLOG" 2>&1 < /dev/null
+
+ # Create directory for postmaster log
+ mkdir "$PGDATA/pg_log"
+ chown postgres:postgres "$PGDATA/pg_log"
+ chmod go-rwx "$PGDATA/pg_log"
+
+ if [ -f "$PGDATA/PG_VERSION" ]
+ then
+ echo -n " [ OK ] "
+ else
+ echo -n " [FAILED] "
+ script_result=1
+ fi
+ echo
+ fi
+}
+
+case "$1" in
+ initdb)
+ initdb
+ ;;
+ *)
+ echo "Usage: $0 initdb"
+ exit 2
+esac
+
+exit $script_result
diff --git a/meta-oe/recipes-dbs/postgresql/files/postgresql.init b/meta-oe/recipes-dbs/postgresql/files/postgresql.init
new file mode 100644
index 0000000000..4a4f0cd168
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/postgresql.init
@@ -0,0 +1,193 @@
+#!/bin/sh
+#
+# postgresql This is the init script for starting up the PostgreSQL
+# server.
+#
+# chkconfig: - 64 36
+# description: PostgreSQL database server.
+# processname: postmaster
+# pidfile: /var/run/postmaster.PORT.pid
+
+# This script is slightly unusual in that the name of the daemon (postmaster)
+# is not the same as the name of the subsystem (postgresql)
+
+# PGVERSION is the full package version, e.g., 8.4.0
+# Note: the specfile inserts the correct value during package build
+PGVERSION=9.2.4
+# PGMAJORVERSION is major version, e.g., 8.4 (this should match PG_VERSION)
+PGMAJORVERSION=`echo "$PGVERSION" | sed 's/^\([0-9]*\.[0-9]*\).*$/\1/'`
+
+# Source function library.
+. /etc/init.d/functions
+
+# Find the name of the script
+NAME=`basename $0`
+if [ ${NAME:0:1} = "S" -o ${NAME:0:1} = "K" ]
+then
+ NAME=${NAME:3}
+fi
+
+# For SELinux we need to use 'runuser' not 'su'
+if [ -x /sbin/runuser ]
+then
+ SU=runuser
+else
+ SU=su
+fi
+
+
+# Set defaults for configuration variables
+PGENGINE=/usr/bin
+PGPORT=5432
+PGDATA=/var/lib/postgresql/data
+PGLOG=/var/lib/postgresql/pgstartup.log
+# Value to set as postmaster process's oom_adj
+PG_OOM_ADJ=-17
+
+# Override defaults from /etc/sysconfig/postgresql if file is present
+[ -f /etc/default/postgresql/${NAME} ] && . /etc/default/postgresql/${NAME}
+
+export PGDATA
+export PGPORT
+
+lockfile="/var/lock/subsys/${NAME}"
+pidfile="/var/run/postmaster.${PGPORT}.pid"
+
+script_result=0
+
+start(){
+ [ -x "$PGENGINE/postmaster" ] || exit 5
+
+ PSQL_START=$"Starting ${NAME} service: "
+
+ # Make sure startup-time log file is valid
+ if [ ! -e "$PGLOG" -a ! -h "$PGLOG" ]
+ then
+ touch "$PGLOG" || exit 4
+ chown postgres:postgres "$PGLOG"
+ chmod go-rwx "$PGLOG"
+ [ -x /sbin/restorecon ] && /sbin/restorecon "$PGLOG"
+ fi
+
+ # Check for the PGDATA structure
+ if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+ then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` != x"$PGMAJORVERSION" ]
+ then
+ SYSDOCDIR="(Your System's documentation directory)"
+ if [ -d "/usr/doc/postgresql-$PGVERSION" ]
+ then
+ SYSDOCDIR=/usr/doc
+ fi
+ if [ -d "/usr/share/doc/postgresql-$PGVERSION" ]
+ then
+ SYSDOCDIR=/usr/share/doc
+ fi
+ if [ -d "/usr/doc/packages/postgresql-$PGVERSION" ]
+ then
+ SYSDOCDIR=/usr/doc/packages
+ fi
+ if [ -d "/usr/share/doc/packages/postgresql-$PGVERSION" ]
+ then
+ SYSDOCDIR=/usr/share/doc/packages
+ fi
+ echo
+ echo $"An old version of the database format was found."
+ echo $"You need to upgrade the data format before using PostgreSQL."
+ echo $"See $SYSDOCDIR/postgresql-$PGVERSION/README.rpm-dist for more information."
+ exit 1
+ fi
+ else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo
+ echo "$PGDATA is missing. Use \"postgresql-setup initdb\" to initialize the cluster first."
+ echo -n " [FAILED] "
+ echo
+ exit 1
+ fi
+
+ echo -n "$PSQL_START"
+ test x"$PG_OOM_ADJ" != x && echo "$PG_OOM_ADJ" > /proc/self/oom_score_adj
+ $SU -l postgres -c "$PGENGINE/postmaster -p '$PGPORT' -D '$PGDATA' ${PGOPTS} &" >> "$PGLOG" 2>&1 < /dev/null
+ sleep 2
+ pid=`head -n 1 "$PGDATA/postmaster.pid" 2>/dev/null`
+ if [ "x$pid" != x ]
+ then
+ echo -n " [ OK ]"
+ touch "$lockfile"
+ echo $pid > "$pidfile"
+ echo
+ else
+ echo -n " [FAILED]"
+ echo
+ script_result=1
+ fi
+}
+
+stop(){
+ echo -n $"Stopping ${NAME} service: "
+ if [ -e "$lockfile" ]
+ then
+ $SU -l postgres -c "$PGENGINE/pg_ctl stop -D '$PGDATA' -s -m fast" > /dev/null 2>&1 < /dev/null
+ ret=$?
+ if [ $ret -eq 0 ]
+ then
+ echo -n " [ OK ] "
+ rm -f "$pidfile"
+ rm -f "$lockfile"
+ else
+ echo -n " [FAILED] "
+ script_result=1
+ fi
+ else
+ # not running; per LSB standards this is "ok"
+ echo -n " [ OK ] "
+ fi
+ echo
+}
+
+restart(){
+ stop
+ start
+}
+
+condrestart(){
+ [ -e "$lockfile" ] && restart || :
+}
+
+reload(){
+ $SU -l postgres -c "$PGENGINE/pg_ctl reload -D '$PGDATA' -s" > /dev/null 2>&1 < /dev/null
+}
+
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ status)
+ status postmaster
+ script_result=$?
+ ;;
+ restart)
+ restart
+ ;;
+ condrestart|try-restart)
+ condrestart
+ ;;
+ reload)
+ reload
+ ;;
+ force-reload)
+ restart
+ ;;
+ *)
+ echo $"Usage: $0 {start|stop|status|restart|condrestart|try-restart|reload|force-reload}"
+ exit 2
+esac
+
+exit $script_result
diff --git a/meta-oe/recipes-dbs/postgresql/files/postgresql.pam b/meta-oe/recipes-dbs/postgresql/files/postgresql.pam
new file mode 100644
index 0000000000..0b6fdc5f26
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/postgresql.pam
@@ -0,0 +1,4 @@
+#%PAM-1.0
+auth include common-auth
+account include common-account
+password include common-password
diff --git a/meta-oe/recipes-dbs/postgresql/files/postgresql.service b/meta-oe/recipes-dbs/postgresql/files/postgresql.service
new file mode 100644
index 0000000000..4ec959e842
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/postgresql.service
@@ -0,0 +1,27 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+User=postgres
+Group=postgres
+
+# Port number for server to listen on
+Environment=PGPORT=5432
+
+# Location of database directory
+Environment=PGDATA=/var/lib/postgresql/data
+
+# Disable OOM kill on the postmaster
+OOMScoreAdjust=-17
+
+ExecStart=@BINDIR@/pg_ctl start -D ${PGDATA} -s -o "-p ${PGPORT}" -w -t 300
+ExecStop=@BINDIR@/pg_ctl stop -D ${PGDATA} -s -m fast
+ExecReload=@BINDIR@/pg_ctl reload -D ${PGDATA} -s
+
+# Give a reasonable amount of time for the server to start up/shut down
+TimeoutSec=300
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-oe/recipes-dbs/postgresql/files/remove.autoconf.version.check.patch b/meta-oe/recipes-dbs/postgresql/files/remove.autoconf.version.check.patch
new file mode 100644
index 0000000000..be23fd419d
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/remove.autoconf.version.check.patch
@@ -0,0 +1,16 @@
+Index: postgresql-9.2.4/configure.in
+===================================================================
+--- postgresql-9.2.4.orig/configure.in
++++ postgresql-9.2.4/configure.in
+@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch un
+
+ AC_INIT([PostgreSQL], [9.4.2], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
+
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
new file mode 100644
index 0000000000..812c2aed48
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -0,0 +1,383 @@
+SUMMARY = "PostgreSQL is a powerful, open source relational database system."
+DESCRIPTION = "\
+ PostgreSQL is an advanced Object-Relational database management system \
+ (DBMS) that supports almost all SQL constructs (including \
+ transactions, subselects and user-defined types and functions). The \
+ postgresql package includes the client programs and libraries that \
+ you'll need to access a PostgreSQL DBMS server. These PostgreSQL \
+ client programs are programs that directly manipulate the internal \
+ structure of PostgreSQL databases on a PostgreSQL server. These client \
+ programs can be located on the same machine with the PostgreSQL \
+ server, or may be on a remote machine which accesses a PostgreSQL \
+ server over a network connection. This package contains the docs \
+ in HTML for the whole package, as well as command-line utilities for \
+ managing PostgreSQL databases on a PostgreSQL server. \
+ \
+ If you want to manipulate a PostgreSQL database on a local or remote \
+ PostgreSQL server, you need this package. You also need to install \
+ this package if you're installing the postgresql-server package. \
+"
+HOMEPAGE = "http://www.postgresql.com"
+LICENSE = "BSD"
+DEPENDS = "zlib readline tzcode-native"
+
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \
+ file://postgresql.init \
+ file://postgresql-bashprofile \
+ file://postgresql.pam \
+ file://postgresql-setup \
+ file://postgresql.service \
+ file://0001-Use-pkg-config-for-libxml2-detection.patch \
+"
+
+LEAD_SONAME = "libpq.so"
+
+# LDFLAGS for shared libraries
+export LDFLAGS_SL = "${LDFLAGS}"
+
+inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext
+
+CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"
+
+SYSTEMD_SERVICE_${PN} = "postgresql.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-systemctl-native', '', d)}"
+pkg_postinst_${PN} () {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd sysvinit', 'true', 'false', d)}; then
+ if [ -n "$D" ]; then
+ OPTS="--root=$D"
+ fi
+ systemctl $OPTS mask postgresql-server.service
+ fi
+}
+
+enable_pam = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
+PACKAGECONFIG ??= "${enable_pam} openssl python uuid libxml tcl nls libxml perl"
+PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
+PACKAGECONFIG[python] = "--with-python,--without-python,python,python"
+PACKAGECONFIG[uuid] = "--with-ossp-uuid,--without-ossp-uuid,ossp-uuid,"
+PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl tcl-native,"
+PACKAGECONFIG[nls] = "--enable-nls,--disable-nls,,"
+PACKAGECONFIG[libxml] = "--with-libxml,--without-libxml,libxml2,libxml2"
+PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl"
+
+EXTRA_OECONF += "--enable-thread-safety --disable-rpath \
+ --datadir=${datadir}/${BPN} \
+ --sysconfdir=${sysconfdir}/${BPN} \
+"
+EXTRA_OECONF_sh4 += "--disable-spinlocks"
+EXTRA_OECONF_aarch64 += "--disable-spinlocks"
+
+PACKAGES_DYNAMIC += "^${PN}-plperl ^${PN}-plperl-dbg \
+ ^${PN}-pltcl ^${PN}-pltcl-dbg \
+ ^${PN}-plpython ^${PN}-plpython-dbg \
+"
+
+python populate_packages_prepend() {
+
+ def fill_more(name, dbg=True):
+ if name is None or name.strip() == "":
+ return
+
+ fpack=d.getVar('PACKAGES', False) or ""
+ fpack="${PN}-" + name + " " + fpack
+ if dbg:
+ fpack="${PN}-" + name + "-dbg" + " " + fpack
+ d.setVar('PACKAGES', fpack)
+
+ conf=(d.getVar('PACKAGECONFIG') or "").split()
+ pack=d.getVar('PACKAGES', False) or ""
+ bb.debug(1, "PACKAGECONFIG=%s" % conf)
+ bb.debug(1, "PACKAGES1=%s" % pack )
+
+ if "perl" in conf :
+ fill_more("plperl")
+
+ if "tcl" in conf:
+ fill_more("pltcl")
+
+ if "python" in conf:
+ fill_more("plpython")
+
+ pack=d.getVar('PACKAGES') or ""
+ bb.debug(1, "PACKAGES2=%s" % pack)
+
+}
+
+do_configure() {
+ # do_configure
+ autotools_do_configure
+
+ # do_configure_append
+ # workaround perl package related bugs
+ sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \
+ ${B}/src/Makefile.global
+ LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native"
+ LIBNA="\${STAGING_LIBDIR_NATIVE}"
+ BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}"
+ sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
+ ${B}/src/Makefile.global
+ sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
+ ${B}/src/Makefile.global
+ # remove the rpath, replace with correct lib path
+ sed -i \
+ -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \
+ -e "/^perl_embed_ldflags/s:-Wl,-rpath,${BLIBNA}::g" \
+ -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${LIBNA}::g" \
+ -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${BLIBNA}::g" \
+ -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
+ -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \
+ -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \
+ -e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \
+ ${B}/src/Makefile.global
+
+ if ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'true', 'false', d)}; then
+ # workaround perl package's libperl.so problem
+ # we are using perlnative so this perl should have same version
+ perl_version=`perl -v 2>/dev/null | \
+ sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
+ if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
+ ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
+ ln -sf ../../../libperl.so.5 \
+ ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
+ fi
+ fi
+}
+
+do_compile_append() {
+ oe_runmake -C contrib all
+}
+
+# server needs to configure user and group
+usernum = "28"
+groupnum = "28"
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "-M -g postgres -o -r -d ${localstatedir}/lib/${BPN} \
+ -s /bin/bash -c 'PostgreSQL Server' -u ${usernum} postgres"
+GROUPADD_PARAM_${PN} = "-g ${groupnum} -o -r postgres"
+
+INITSCRIPT_PACKAGES = "${PN}"
+INITSCRIPT_NAME = "${BPN}-server"
+INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ."
+
+do_install_append() {
+ # install contrib
+ oe_runmake DESTDIR=${D} -C contrib install
+ # install tutorial
+ install -d -m 0755 ${D}${libdir}/${BPN}/tutorial
+ install ${B}/src/tutorial/* ${D}${libdir}/${BPN}/tutorial
+
+ # install COPYRIGHT README HISTORY
+ install -d -m 0755 ${D}${docdir}/${BPN}
+ for i in ${B}/COPYRIGHT ${B}/README ${B}/HISTORY ${B}/doc/KNOWN_BUGS ${B}/doc/MISSING_FEATURES ${B}/doc/README* ${B}/doc/bug.template; do
+ [ -f $i ] && install $i ${D}${docdir}/${BPN}
+ done
+
+ # install dirs and server init
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/${BPN}.init ${D}${sysconfdir}/init.d/${BPN}-server
+ sed -i -e "s/^PGVERSION=.*$/PGVERSION=${PV}/g" ${D}${sysconfdir}/init.d/${BPN}-server
+ install -m 0755 ${WORKDIR}/${BPN}-setup ${D}${bindir}/${BPN}-setup
+ install -d -m 700 ${D}${localstatedir}/lib/${BPN}/data
+ install -d -m 700 ${D}${localstatedir}/lib/${BPN}/backups
+ install -m 644 ${WORKDIR}/${BPN}-bashprofile ${D}${localstatedir}/lib/${BPN}/.bash_profile
+ chown -R postgres:postgres ${D}${localstatedir}/lib/${BPN}
+ # multiple server config directory
+ install -d -m 700 ${D}${sysconfdir}/default/${BPN}
+
+ if [ "${@d.getVar('enable_pam')}" = "pam" ]; then
+ install -d ${D}${sysconfdir}/pam.d
+ install -m 644 ${WORKDIR}/postgresql.pam ${D}${sysconfdir}/pam.d/postgresql
+ fi
+
+ # Install systemd unit files
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/postgresql.service ${D}${systemd_unitdir}/system
+ sed -i -e 's,@BINDIR@,${bindir},g' \
+ ${D}${systemd_unitdir}/system/postgresql.service
+}
+
+SSTATE_SCAN_FILES += "Makefile.global"
+
+PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \
+ libecpg-compat-dbg libecpg-compat libecpg-compat-dev \
+ libecpg-dbg libecpg libecpg-dev libecpg-staticdev libecpg-doc \
+ libpq-dbg libpq libpq-dev libpq-staticdev \
+ libpgtypes-dbg libpgtypes libpgtypes-staticdev libpgtypes-dev \
+ ${PN}-contrib ${PN}-contrib-dbg \
+"
+
+FILES_${PN} += "${sysconfdir}/init.d/${BPN}-server \
+ ${localstatedir}/lib/${BPN}/data ${localstatedir}/lib/${BPN}/backups \
+ ${localstatedir}/lib/${BPN}/.bash_profile ${sysconfdir}/default/${BPN} \
+ ${libdir}/${BPN}/dict_snowball.so ${libdir}/${BPN}/plpgsql.so \
+ ${libdir}/${BPN}/euc2004_sjis2004.so \
+ ${libdir}/${BPN}/libpqwalreceiver.so \
+ ${libdir}/${BPN}/*_and_*.so \
+ ${@'${sysconfdir}/pam.d/postgresql' \
+ if 'pam' == d.getVar('enable_pam') \
+ else ''} \
+"
+
+FILES_${PN}-dbg += " ${libdir}/${BPN}/.debug/dict_snowball.so \
+ ${libdir}/${BPN}/.debug/plpgsql.so \
+ ${libdir}/${BPN}/.debug/euc2004_sjis2004.so \
+ ${libdir}/${BPN}/.debug/libpqwalreceiver.so \
+ ${libdir}/${BPN}/.debug/*_and_*.so \
+"
+
+FILES_${PN}-client = "${bindir}/clusterdb \
+ ${bindir}/createdb \
+ ${bindir}/createlang \
+ ${bindir}/createuser \
+ ${bindir}/dropdb \
+ ${bindir}/droplang \
+ ${bindir}/dropuser \
+ ${bindir}/pg_dump \
+ ${bindir}/pg_dumpall \
+ ${bindir}/pg_restore \
+ ${bindir}/psql \
+ ${bindir}/reindexdb \
+ ${bindir}/vacuumdb \
+ ${bindir}/vacuumlo \
+ ${datadir}/${BPN}/psqlrc.sample \
+"
+FILES_${PN}-client-doc = "${mandir}/man1/clusterdb.* \
+ ${mandir}/man1/createdb.* ${mandir}/man1/createlang.* \
+ ${mandir}/man1/createuser.* ${mandir}/man1/dropdb.* \
+ ${mandir}/man1/droplang.* ${mandir}/man1/dropuser.* \
+ ${mandir}/man1/pg_dump.* ${mandir}/man1/pg_dumpall.* \
+ ${mandir}/man1/pg_restore.* ${mandir}/man1/psql.* \
+ ${mandir}/man1/reindexdb.* ${mandir}/man1/vacuumdb.* \
+ ${mandir}/man7/* \
+"
+FILES_${PN}-doc += "${docdir}/${BPN}/html ${libdir}/${BPN}/tutorial/ \
+ ${mandir}/man1/initdb.* ${mandir}/man1/pg_controldata.* \
+ ${mandir}/man1/pg_ctl.* ${mandir}/man1/pg_resetxlog.* \
+ ${mandir}/man1/postgres.* ${mandir}/man1/postmaster.* \
+"
+FILES_${PN}-timezone = "${datadir}/${BPN}/timezone \
+ ${datadir}/${BPN}/timezonesets \
+"
+RDEPENDS_${PN} += "${PN}-timezone"
+FILES_${PN}-server-dev = "${includedir}/${BPN}/server"
+
+FILES_libecpg = "${libdir}/libecpg*${SOLIBS}"
+FILES_libecpg-dbg = "${libdir}/.debug/libecpg*"
+FILES_libecpg-dev = "${libdir}/libecpg*${SOLIBSDEV} \
+ ${libdir}/libpgtypes*${SOLIBSDEV} \
+ ${includedir}/ecpg*.h ${includedir}/${BPN}/ecpg*.h \
+ ${includedir}/pgtypes*.h ${includedir}/${BPN}/informix \
+ ${includedir}/sql3types.h ${includedir}/sqlca.h \
+"
+FILES_libecpg-doc = "${mandir}/man1/ecpg.*"
+FILES_libecpg-staticdev = "${libdir}/libecpg*.a"
+SECTION_libecpg-staticdev = "devel"
+RDEPENDS_libecpg-staticdev = "libecpg-dev (= ${EXTENDPKGV})"
+
+FILES_libpq = "${libdir}/libpq*${SOLIBS}"
+FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${BPN}/pgxs/src/test/regress/.debug/*"
+FILES_libpq-dev = "${libdir}/libpq*${SOLIBSDEV} \
+ ${includedir} \
+"
+FILES_libpq-staticdev = "${libdir}/libpq*.a ${libdir}/libpgport.a"
+SECTION_libpq-staticdev = "devel"
+RDEPENDS_libpq-staticdev = "libpq-dev (= ${EXTENDPKGV})"
+
+FILES_libecpg-compat = "${libdir}/libecpg_compat*${SOLIBS}"
+FILES_libecpg-compat-dbg = "${libdir}/.debug/libecpg_compat*"
+FILES_libecpg-compat-dev = "${libdir}/libecpg_compat*${SOLIBS}"
+FILES_libpgtypes = "${libdir}/libpgtypes*${SOLIBS}"
+FILES_libpgtypes-dbg = "${libdir}/.debug/libpgtypes*"
+FILES_libpgtypes-staticdev = "${libdir}/libpgtypes*.a"
+FILES_libpgtypes-dev = "${libdir}/libpgtypes*${SOLIBS} ${includedir}/pgtypes*.h"
+
+FILES_${PN}-contrib = " ${bindir}/oid2name ${bindir}/pg_standby \
+ ${bindir}/pgbench ${bindir}/vacuumlo \
+ ${S}/contrib/spi/*.example \
+ ${libdir}/${BPN}/_int.so ${libdir}/${BPN}/adminpack.so \
+ ${libdir}/${BPN}/autoinc.so ${libdir}/${BPN}/auto_explain.so \
+ ${libdir}/${BPN}/auth_delay.so ${libdir}/${BPN}/btree_gin.so \
+ ${libdir}/${BPN}/btree_gist.so ${libdir}/${BPN}/.so \
+ ${libdir}/${BPN}/chkpass.so ${libdir}/${BPN}/citext.so \
+ ${libdir}/${BPN}/cube.so ${libdir}/${BPN}/dblink.so \
+ ${libdir}/${BPN}/dict_int.so ${libdir}/${BPN}/dict_xsyn.so \
+ ${libdir}/${BPN}/dummy_seclabel.so ${libdir}/${BPN}/earthdistance.so \
+ ${libdir}/${BPN}/file_fdw.so ${libdir}/${BPN}/fuzzystrmatch.so \
+ ${libdir}/${BPN}/hstore.so ${libdir}/${BPN}/insert_username.so \
+ ${libdir}/${BPN}/isn.so ${libdir}/${BPN}/lo.so \
+ ${libdir}/${BPN}/ltree.so ${libdir}/${BPN}/moddatetime.so \
+ ${libdir}/${BPN}/pageinspect.so ${libdir}/${BPN}/pg_buffercache.so \
+ ${libdir}/${BPN}/pg_freespacemap.so ${libdir}/${BPN}/pg_trgm.so \
+ ${libdir}/${BPN}/pgcrypto.so ${libdir}/${BPN}/pgrowlocks.so \
+ ${libdir}/${BPN}/pgstattuple.so ${libdir}/${BPN}/pg_stat_statements.so \
+ ${libdir}/${BPN}/refint.so ${libdir}/${BPN}/seg.so \
+ ${libdir}/${BPN}/sslinfo.so \
+ ${libdir}/${BPN}/tablefunc.so \
+ ${libdir}/${BPN}/test_parser.so ${libdir}/${BPN}/timetravel.so \
+ ${libdir}/${BPN}/tsearch2.so ${libdir}/${BPN}/uuid-ossp.so \
+ ${libdir}/${BPN}/pgxml.so ${libdir}/${BPN}/passwordcheck.so \
+ ${libdir}/${BPN}/pg_upgrade_support.so ${libdir}/${BPN}/.so \
+ ${libdir}/${BPN}/unaccent.so \
+"
+FILES_${PN}-contrib-dbg = " \
+ ${libdir}/${BPN}/.debug/_int.so ${libdir}/${BPN}/.debug/adminpack.so \
+ ${libdir}/${BPN}/.debug/autoinc.so ${libdir}/${BPN}/.debug/auto_explain.so \
+ ${libdir}/${BPN}/.debug/auth_delay.so ${libdir}/${BPN}/.debug/btree_gin.so \
+ ${libdir}/${BPN}/.debug/btree_gist.so ${libdir}/${BPN}/.debug/.so \
+ ${libdir}/${BPN}/.debug/chkpass.so ${libdir}/${BPN}/.debug/citext.so \
+ ${libdir}/${BPN}/.debug/cube.so ${libdir}/${BPN}/.debug/dblink.so \
+ ${libdir}/${BPN}/.debug/dict_int.so ${libdir}/${BPN}/.debug/dict_xsyn.so \
+ ${libdir}/${BPN}/.debug/dummy_seclabel.so \
+ ${libdir}/${BPN}/.debug/earthdistance.so \
+ ${libdir}/${BPN}/.debug/file_fdw.so ${libdir}/${BPN}/.debug/fuzzystrmatch.so \
+ ${libdir}/${BPN}/.debug/hstore.so ${libdir}/${BPN}/.debug/insert_username.so \
+ ${libdir}/${BPN}/.debug/isn.so ${libdir}/${BPN}/.debug/lo.so \
+ ${libdir}/${BPN}/.debug/ltree.so ${libdir}/${BPN}/.debug/moddatetime.so \
+ ${libdir}/${BPN}/.debug/pageinspect.so \
+ ${libdir}/${BPN}/.debug/pg_buffercache.so \
+ ${libdir}/${BPN}/.debug/pg_freespacemap.so \
+ ${libdir}/${BPN}/.debug/pg_trgm.so \
+ ${libdir}/${BPN}/.debug/pgcrypto.so ${libdir}/${BPN}/.debug/pgrowlocks.so \
+ ${libdir}/${BPN}/.debug/pgstattuple.so \
+ ${libdir}/${BPN}/.debug/pg_stat_statements.so \
+ ${libdir}/${BPN}/.debug/refint.so ${libdir}/${BPN}/.debug/seg.so \
+ ${libdir}/${BPN}/.debug/sslinfo.so \
+ ${libdir}/${BPN}/.debug/tablefunc.so \
+ ${libdir}/${BPN}/.debug/test_parser.so ${libdir}/${BPN}/.debug/timetravel.so \
+ ${libdir}/${BPN}/.debug/tsearch2.so ${libdir}/${BPN}/.debug/uuid-ossp.so \
+ ${libdir}/${BPN}/.debug/pgxml.so ${libdir}/${BPN}/.debug/passwordcheck.so \
+ ${libdir}/${BPN}/.debug/pg_upgrade_support.so \
+ ${libdir}/${BPN}/.debug/unaccent.so \
+"
+DESCRIPTION_${PN}-contrib = "The postgresql-contrib package contains \
+ contributed packages that are included in the PostgreSQL distribution."
+
+FILES_${PN}-pltcl = "${libdir}/${BPN}/pltcl.so ${bindir}/pltcl_delmod \
+ ${binddir}/pltcl_listmod ${bindir}/pltcl_loadmod \
+ ${datadir}/${BPN}/unknown.pltcl"
+FILES_${PN}-pltcl-dbg = "${libdir}/${BPN}/.debug/pltcl.so"
+SUMMARY_${PN}-pltcl = "The Tcl procedural language for PostgreSQL"
+DESCRIPTION_${PN}-pltcl = "PostgreSQL is an advanced Object-Relational \
+ database management system. The postgresql-pltcl package contains the PL/Tcl \
+ procedural language for the backend."
+
+FILES_${PN}-plperl = "${libdir}/${BPN}/plperl.so"
+FILES_${PN}-plperl-dbg = "${libdir}/${BPN}/.debug/plperl.so"
+SUMMARY_${PN}-plperl = "The Perl procedural language for PostgreSQL"
+DESCRIPTION_${PN}-plperl = "PostgreSQL is an advanced Object-Relational \
+ database management system. The postgresql-plperl package contains the \
+ PL/Perl procedural language for the backend."
+
+# In version 8, it will be plpython.so
+# In version 9, it might be plpython{2,3}.so depending on python2 or 3
+FILES_${PN}-plpython = "${libdir}/${BPN}/plpython*.so"
+FILES_${PN}-plpython-dbg = "${libdir}/${BPN}/.debug/plpython*.so"
+SUMMARY_${PN}-plpython = "The Python procedural language for PostgreSQL"
+DESCRIPTION_${PN}-plpython = "PostgreSQL is an advanced Object-Relational \
+ database management system. The postgresql-plpython package contains \
+ the PL/Python procedural language for the backend."
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_9.4.15.bb b/meta-oe/recipes-dbs/postgresql/postgresql_9.4.15.bb
new file mode 100644
index 0000000000..eec099a129
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/postgresql_9.4.15.bb
@@ -0,0 +1,15 @@
+require postgresql.inc
+
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=81b69ddb31a8be66baafd14a90146ee2"
+
+SRC_URI += "\
+ file://remove.autoconf.version.check.patch \
+ file://not-check-libperl.patch \
+"
+
+do_compile_prepend_libc-musl() {
+ sed -i -e 's/\-lnsl//g' ${B}/src/Makefile.global
+}
+
+SRC_URI[md5sum] = "0aada0833a9208ae5fab966c73c39379"
+SRC_URI[sha256sum] = "12bfb3c7e8e45515ef921ad365e122682a5c4935dcc0032644433af2de31acc4"