aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 16:33:15 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit505774658338002a92c2e32c4c57c55f36c5e36e (patch)
treec5d1032aac37af7493141cdfa56da5b371ce5a59 /meta-oe/recipes-dbs
parent66454b26ff49c6cca3dd8d32832078cfa05cd5ef (diff)
downloadmeta-openembedded-505774658338002a92c2e32c4c57c55f36c5e36e.tar.gz
meta-oe: Remove using python2
This change makes the parsing go though, we still might have build issues, which will be reported in world builds seprately Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb2
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
index f2faec1c13..6d52222ce4 100644
--- a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
+++ b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
@@ -16,4 +16,4 @@ SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools
+inherit setuptools3
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index 91d0275b3b..8ecf2fd3ca 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -37,7 +37,7 @@ LEAD_SONAME = "libpq.so"
# LDFLAGS for shared libraries
export LDFLAGS_SL = "${LDFLAGS}"
-inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext cpan-base
+inherit autotools pkgconfig perlnative python3native useradd update-rc.d systemd gettext cpan-base
CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"