aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cgdb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-10-30 11:12:57 +0200
committerKhem Raj <raj.khem@gmail.com>2019-11-01 17:22:52 -0700
commit840f24a68d1df08ea6ff39e5b2b33fa410cab112 (patch)
treef2110936390909ab3b64fc722111b99cb27649f5 /meta-oe/recipes-devtools/cgdb
parent301972a0c8f7ec9b843ddb9a48bd87b7e71760b6 (diff)
downloadmeta-openembedded-840f24a68d1df08ea6ff39e5b2b33fa410cab112.tar.gz
cgdb: Upgrade 0.6.8 -> 0.7.1
Obsolete patch removed. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cgdb')
-rw-r--r--meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch67
-rw-r--r--meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch47
-rw-r--r--meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb (renamed from meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb)9
3 files changed, 72 insertions, 51 deletions
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch b/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch
new file mode 100644
index 0000000000..daf90ad44d
--- /dev/null
+++ b/meta-oe/recipes-devtools/cgdb/cgdb/0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch
@@ -0,0 +1,67 @@
+From a3eba0fcee5e96ef47a6d3fac7196a1074f0dc17 Mon Sep 17 00:00:00 2001
+From: Adrian Bunk <bunk@stusta.de>
+Date: Wed, 30 Oct 2019 11:07:23 +0200
+Subject: Avoid use of "mips" which is reserved on mips
+
+Upstream-Status: Submitted [https://github.com/brasko/gdbwire/pull/9]
+
+Signed-off-by: Adrian Bunk <bunk@stusta.de>
+
+diff --git a/src/gdbwire_mi_parser.c b/src/gdbwire_mi_parser.c
+index 3f6b563..24aa0cf 100644
+--- a/lib/tgdb/gdbwire.c
++++ b/lib/tgdb/gdbwire.c
+@@ -40,7 +40,7 @@ struct gdbwire_mi_parser {
+ /* The GDB/MI lexer state */
+ yyscan_t mils;
+ /* The GDB/MI push parser state */
+- gdbwire_mi_pstate *mips;
++ gdbwire_mi_pstate *mipst;
+ /* The client parser callbacks */
+ struct gdbwire_mi_parser_callbacks callbacks;
+ };
+@@ -71,8 +71,8 @@ gdbwire_mi_parser_create(struct gdbwire_mi_parser_callbacks callbacks)
+ }
+
+ /* Create a new push parser state instance */
+- parser->mips = gdbwire_mi_pstate_new();
+- if (!parser->mips) {
++ parser->mipst = gdbwire_mi_pstate_new();
++ if (!parser->mipst) {
+ gdbwire_mi_lex_destroy(parser->mils);
+ gdbwire_string_destroy(parser->buffer);
+ free(parser);
+@@ -81,7 +81,7 @@ gdbwire_mi_parser_create(struct gdbwire_mi_parser_callbacks callbacks)
+
+ /* Ensure that the callbacks are non null */
+ if (!callbacks.gdbwire_mi_output_callback) {
+- gdbwire_mi_pstate_delete(parser->mips);
++ gdbwire_mi_pstate_delete(parser->mipst);
+ gdbwire_mi_lex_destroy(parser->mils);
+ gdbwire_string_destroy(parser->buffer);
+ free(parser);
+@@ -109,9 +109,9 @@ void gdbwire_mi_parser_destroy(struct gdbwire_mi_parser *parser)
+ }
+
+ /* Free the push parser instance */
+- if (parser->mips) {
+- gdbwire_mi_pstate_delete(parser->mips);
+- parser->mips = NULL;
++ if (parser->mipst) {
++ gdbwire_mi_pstate_delete(parser->mipst);
++ parser->mipst = NULL;
+ }
+
+ free(parser);
+@@ -162,7 +162,7 @@ gdbwire_mi_parser_parse_line(struct gdbwire_mi_parser *parser,
+ pattern = gdbwire_mi_lex(parser->mils);
+ if (pattern == 0)
+ break;
+- mi_status = gdbwire_mi_push_parse(parser->mips, pattern, NULL,
++ mi_status = gdbwire_mi_push_parse(parser->mipst, pattern, NULL,
+ parser->mils, &output);
+ } while (mi_status == YYPUSH_MORE);
+
+--
+2.20.1
+
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch b/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch
deleted file mode 100644
index 4358629b7b..0000000000
--- a/meta-oe/recipes-devtools/cgdb/cgdb/remove-help2man.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Disable building manpages so that make install doesn't fail due to lack of help2man
-
-Upstream-Status: Inappropriate [config]
-
-Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
----
- configure.ac | 3 ---
- doc/Makefile.am | 5 -----
- 2 files changed, 8 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index ee7eca0..1f0d924 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -134,9 +134,6 @@ dnl check that the required tools are available to generate documentation
- if test "$HAS_MAKEINFO" != "yes" ; then
- AC_MSG_ERROR([Please install makeinfo before installing])
- fi
--if test "$HAS_HELP2MAN" != "yes" ; then
-- AC_MSG_ERROR([Please install help2man])
--fi
-
- dnl Checking for log10 function in math - I would like to remove this
- AC_CHECK_LIB(m, log10)
-diff --git a/doc/Makefile.am b/doc/Makefile.am
-index 60662f6..0ae0013 100644
---- a/doc/Makefile.am
-+++ b/doc/Makefile.am
-@@ -1,15 +1,10 @@
- info_TEXINFOS = cgdb.texi
- cgdb_TEXINFOS = gpl.texi
-
--dist_man_MANS = cgdb.1
- EXTRA_DIST = cgdb.txt
-
- dist_pkgdata_DATA = cgdb.txt
-
--# generate the man page using help2man.
--cgdb.1:
-- help2man --output=$(top_srcdir)/doc/cgdb.1 $(top_builddir)/cgdb/cgdb$(EXEEXT)
--
- cgdb.txt: cgdb.texi $(srcdir)/version.texi $(cgdb_TEXINFOS)
- TEXTS = cgdb.txt
- text-am: $(TEXTS)
---
-1.9.1
-
diff --git a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb b/meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb
index 74019fb622..57e364e1ca 100644
--- a/meta-oe/recipes-devtools/cgdb/cgdb_0.6.8.bb
+++ b/meta-oe/recipes-devtools/cgdb/cgdb_0.7.1.bb
@@ -10,11 +10,12 @@ DEPENDS = "flex-native readline ncurses"
inherit autotools
SRC_URI = "http://cgdb.me/files/${BP}.tar.gz \
- file://remove-help2man.patch"
-SRC_URI[md5sum] = "7bd38c79bf4d794d239928fef401fca3"
-SRC_URI[sha256sum] = "be203e29be295097439ab67efe3dc8261f742c55ff3647718d67d52891f4cf41"
+ file://0001-Avoid-use-of-mips-which-is-reserved-on-mips.patch \
+"
+SRC_URI[md5sum] = "a104862ffd3145b076303992e9a3af26"
+SRC_URI[sha256sum] = "bb723be58ec68cb59a598b8e24a31d10ef31e0e9c277a4de07b2f457fe7de198"
-CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2"
+CACHED_CONFIGUREVARS = "ac_cv_file__dev_ptmx=yes ac_cv_rl_version=6.2 ac_cv_file__proc_self_status=yes"
EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR} \
--with-ncurses=${STAGING_LIBDIR}"