aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-09-06 09:11:58 +0800
committerArmin Kuster <akuster808@gmail.com>2021-09-06 11:58:58 -0700
commit08ff683e00d0920c58c2ec99404d96f3af18e5e8 (patch)
treed31470961b8b0f0f5b209e97f2c869fe2f805342 /meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
parent011f049c20c5b9967039373fd3e27c5c1c020f03 (diff)
downloadmeta-openembedded-08ff683e00d0920c58c2ec99404d96f3af18e5e8.tar.gz
cjson: upgrade 1.7.14 -> 1.7.15
Fixes: Fix potential core dumped for strrchr, see https://github.com/DaveGamble/cJSON/pull/546 Fix null pointer crash in cJSON_CreateXxArray, see https://github.com/DaveGamble/cJSON/pull/538 Fix several null pointer problems on allocation failure, see https://github.com/DaveGamble/cJSON/pull/526 Fix a possible dereference of null pointer, see https://github.com/DaveGamble/cJSON/pull/519 Fix windows build failure about defining nan, see https://github.com/DaveGamble/cJSON/pull/518 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit fa00ac02df4e3caabe8ba81d1700cec835bcb139) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb')
-rw-r--r--meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb b/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
new file mode 100644
index 0000000000..1a4e53d508
--- /dev/null
+++ b/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Ultralightweight JSON parser in ANSI C"
+AUTHOR = "Dave Gamble"
+HOMEPAGE = "https://github.com/DaveGamble/cJSON"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git"
+SRCREV = "d348621ca93571343a56862df7de4ff3bc9b5667"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "\
+ -DENABLE_CJSON_UTILS=On \
+ -DENABLE_CUSTOM_COMPILER_FLAGS=OFF \
+ -DBUILD_SHARED_AND_STATIC_LIBS=On \
+"
+
+BBCLASSEXTEND = "native nativesdk"