aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/concurrencykit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-05 19:42:51 -0800
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:45 -0800
commit13d5ab6cf18dfe03a6164ceb4bd580fe19556e8a (patch)
tree2fc286f138ed0afa9d1b0fabbf6bcf76fa6c423c /meta-oe/recipes-devtools/concurrencykit
parent9aecf2944ea8646dfce4085622b4cc6427d2140c (diff)
downloadmeta-openembedded-13d5ab6cf18dfe03a6164ceb4bd580fe19556e8a.tar.gz
concurrencykit: Add recipe for latest from git
Provides concurrency primitives Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/concurrencykit')
-rw-r--r--meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch69
-rw-r--r--meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb40
2 files changed, 109 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch
new file mode 100644
index 0000000000..38504fef6b
--- /dev/null
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit/cross.patch
@@ -0,0 +1,69 @@
+Index: git/configure
+===================================================================
+--- git.orig/configure 2012-11-19 21:07:51.917429465 -0800
++++ git/configure 2012-11-19 21:13:19.337437278 -0800
+@@ -275,8 +275,11 @@
+ assert "$SYSTEM" "$SYSTEM" "unsupported"
+
+ CORES=${CORES:-${DCORES}}
+-printf "Detecting machine architecture..."
+-PLATFORM=`uname -m 2> /dev/null`
++if test -z "$PLATFORM"; then
++ printf "Detecting machine architecture..."
++ PLATFORM=`uname -m 2> /dev/null`
++fi
++
+ case $PLATFORM in
+ "macppc"|"Power Macintosh"|"powerpc")
+ MM="${MM:-"CK_MD_RMO"}"
+@@ -439,14 +442,18 @@
+ GZIP_SUFFIX=".gz"
+ fi
+
+-printf "Finding suitable compiler........"
+-CC=`pathsearch "${CC:-cc}"`
+-if test -z "$CC" -o ! -x "$CC"; then
+- CC=`pathsearch "${CC:-gcc}"`
++if test -z "$CC"; then
++ printf "Finding suitable compiler........"
++ CC=`pathsearch "${CC:-cc}"`
++ if test -z "$CC" -o ! -x "$CC"; then
++ CC=`pathsearch "${CC:-gcc}"`
++ fi
+ fi
+ assert "$CC" "not found"
+
+-cat << EOF > .1.c
++if test -z "$COMPILER"; then
++
++ cat << EOF > .1.c
+ #include <stdio.h>
+ int main(void) {
+ #if defined(__GNUC__) && (__GNUC__ >= 4)
+@@ -460,16 +467,16 @@
+ #endif
+ }
+ EOF
+-
+-$CC -o .1 .1.c
+-COMPILER=`./.1`
+-r=$?
+-rm -f .1.c .1
+-
+-if test "$r" -ne 0; then
+- assert "" "update compiler"
+-else
+- echo "success [$CC]"
++ $CC -o .1 .1.c
++ COMPILER=`./.1`
++ r=$?
++ rm -f .1.c .1
++
++ if test "$r" -ne 0; then
++ assert "" "update compiler"
++ else
++ echo "success [$CC]"
++ fi
+ fi
+
+ if test "$COMPILER" = "suncc"; then
diff --git a/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
new file mode 100644
index 0000000000..b0ff5cf458
--- /dev/null
+++ b/meta-oe/recipes-devtools/concurrencykit/concurrencykit_git.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
+safe memory reclamation mechanisms and non-blocking data structures \
+designed to aid in the design and implementation of high performance \
+concurrent systems."
+
+LICENSE = "BSD & Apache-2.0"
+HOMEPAGE = "http://concurrencykit.org"
+SECTION = "base"
+
+SRCREV = "900d203aa9e41288545368ea40da0bee89f7907f"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f12611e65e064515ce264249b2bdea98"
+SRC_URI = "git://git.concurrencykit.org/ck.git;protocol=git \
+ file://cross.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
+
+inherit autotools
+
+PLAT_powerpc64 = "ppc64"
+PLAT ?= "${HOST_ARCH}"
+
+do_configure () {
+ export PLATFORM=${PLAT}
+ export COMPILER='gcc'
+ ${S}/configure \
+ --prefix=${prefix} \
+ --includedir=${includedir} \
+ --libdir=${libdir} \
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}