aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-26 11:33:07 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-26 14:27:09 -0700
commit0f720e1c051630c36e2dcfc8da166d1710e1c1a5 (patch)
tree73237484a525cf14791e4685af1d41d488f6fdb6 /meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb
parent34007cfda908dcd02fcec912180ccb7da4bb5449 (diff)
downloadmeta-openembedded-0f720e1c051630c36e2dcfc8da166d1710e1c1a5.tar.gz
doxygen: Upgrade 1.8.17 -> 1.8.20
Upgrade to release 1.8.20: - Add configuration setting to have docstrings not as preformatted text but as normal documentation - Bug fix: void return type reported as not documented - Bug fix: Doxywizard 1.8.19 (Windows): Source code directory seems to be ignored - Bug fix: The Doxygen uses too much memory (or has probably a memory leak) - Bug fix: Doxygen doesn't stop on errors - Bug fix: C++ grouped functions in namespace have disappeard - Improvement of line count for e.g. warnings - Improved layout on the bibliography page - Updated the swedish language translation to 1.8.19 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb')
-rw-r--r--meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb b/meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb
new file mode 100644
index 0000000000..d4ac3b7207
--- /dev/null
+++ b/meta-oe/recipes-devtools/doxygen/doxygen_1.8.20.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Doxygen is the de facto standard tool for generating documentation from annotated C++ sources."
+HOMEPAGE = "http://www.doxygen.org/"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "flex-native bison-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.src.tar.gz \
+ file://0001-build-don-t-look-for-Iconv.patch \
+"
+SRC_URI_append_class-native = " file://doxygen-native-only-check-python3.patch"
+SRC_URI[md5sum] = "8729936a843232a66fe970ef65f3c3e4"
+SRC_URI[sha256sum] = "e0db6979286fd7ccd3a99af9f97397f2bae50532e4ecb312aa18862f8401ddec"
+
+inherit cmake python3native
+
+BBCLASSEXTEND = "native nativesdk"