aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/libc-client
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 16:53:10 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-03 14:11:22 +0100
commitb2bed436b4f0e14c1df71a7edfd10b94099e93b7 (patch)
tree1a8d4468838206ef12363a8ef4d3dc61b846db38 /meta-oe/recipes-devtools/libc-client
parent69de108f24567b294d81aec6aae5326ae71ee86e (diff)
downloadmeta-openembedded-b2bed436b4f0e14c1df71a7edfd10b94099e93b7.tar.gz
libc-client: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/libc-client')
-rw-r--r--meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch12
-rw-r--r--meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb32
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
new file mode 100644
index 0000000000..f729ee2074
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
@@ -0,0 +1,12 @@
+diff -urN imap-2007.orig/Makefile imap-2007/Makefile
+--- imap-2007.orig/Makefile 2007-12-20 23:11:10.000000000 +0100
++++ imap-2007/Makefile 2008-03-19 14:08:47.000000000 +0100
+@@ -690,7 +690,7 @@
+ @$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
+ @echo Rebuilding c-client for `$(CAT) OSTYPE`...
+ @$(TOUCH) SPECIALS
+- $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
++ $(CD) c-client;$(MAKE) all CC="`$(CAT) CCTYPE`" \
+ CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
+
+ rebuildclean:
diff --git a/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
new file mode 100644
index 0000000000..e67639ed35
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "UW c-client library for mail protocols"
+SECTION = "devel"
+
+LICENSE = "University of Washingtons Free-Fork License"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a6a4ddbb7cd2999f6827ee143f6fcd97"
+
+DEPENDS = "openssl libpam"
+
+SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
+ file://quote_cctype.patch"
+
+SRC_URI[md5sum] = "7903800dc2604000016de070e0c55840"
+SRC_URI[sha256sum] = "4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f"
+
+S = "${WORKDIR}/imap-${PV}"
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
+
+do_compile() {
+ echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
+ oe_runmake lnp
+}
+
+do_install() {
+ install -d ${D}${includedir}/c-client
+ install ${HEADERS} ${D}${includedir}/c-client
+ install -d ${D}${libdir}
+ install c-client/c-client.a ${D}${libdir}/libc-client.a
+}
+