aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/luajit
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-18 18:45:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-22 13:18:23 +0100
commitf7f166542cc3a3f4ae24d5f6e0bd2efbf00a3a7c (patch)
treed40cad27ffa47eb7b964acf33f5c2d5526d2017b /meta-oe/recipes-devtools/luajit
parent055938e9f7bd7cdba1d5c560eee17f56049953ab (diff)
downloadmeta-openembedded-f7f166542cc3a3f4ae24d5f6e0bd2efbf00a3a7c.tar.gz
luajit_2.0.0.bb: Fix regexpt to change hardcodes path to fix rebuilds
when rebuilding we were running into issues where /usr/lib64 was being made /usr/lib6464 and install was failing. Now we check if /lib is at the end of line then only we replace it. Fixes the reinstall issue Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/luajit')
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
index ac769cf44f..70cefa80b0 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.0.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9511885992e4900014e3b13ca6372b7d"
HOMEPAGE = "http://luajit.org"
DEPENDS += "lua5.1"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \
file://disable_lj_vm_foldarith_for_spe.patch \
"
@@ -17,7 +17,7 @@ inherit pkgconfig binconfig
do_configure_prepend() {
sed -i -e s:/usr/local:${prefix}:g ${S}/Makefile
- sed -i -e s:/lib:${base_libdir}:g ${S}/Makefile
+ sed -i -e s:/lib$:${base_libdir}:g ${S}/Makefile
}
EXTRA_OEMAKE = 'CROSS=${HOST_PREFIX}'