aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mercurial
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-15 11:15:10 -0700
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-19 09:25:55 +0200
commited90232e311fa36eabd3f51bbf6aaaf99a7d24e2 (patch)
tree93032d4dcd30caa9a5a165baf3231088e9e42b9f /meta-oe/recipes-devtools/mercurial
parent7121a25f004b621334074b3c32f2eca0c37a67a1 (diff)
downloadmeta-openembedded-ed90232e311fa36eabd3f51bbf6aaaf99a7d24e2.tar.gz
mercurial-native: Add 1.9 version
This is based on 91c14caa8819b08def8ea99e02949e49604c2e86 from oe.dev with an update to 1.9. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mercurial')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb
new file mode 100644
index 0000000000..b4438a3d03
--- /dev/null
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "The Mercurial distributed SCM"
+HOMEPAGE = "http://mercurial.selenic.com/"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+DEPENDS = "python-native"
+PR = "r1"
+
+SRC_URI = "http://mercurial.selenic.com/release/mercurial-${PV}.tar.gz"
+SRC_URI[md5sum] = "d4842129fa2732eb6ed1180467bc32e2"
+SRC_URI[sha256sum] = "711e4b1cd2924a7a88499d6c431a9122390183bf554d4e153edbb3b2f30123e0"
+
+S = "${WORKDIR}/mercurial-${PV}"
+
+inherit native
+
+EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}"
+
+do_install () {
+ oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
+}
+
+NATIVE_INSTALL_WORKS = "1"