aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ninja
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-08-02 09:00:15 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-08 13:54:02 +0200
commitb0ae995bc813aae651a94092c035a8f5d5253c22 (patch)
tree0da2f5906d396e7c65d0a0628f26d36f563173a1 /meta-oe/recipes-devtools/ninja
parent41414e07d2e842bedcd598199869dc1a2dda7661 (diff)
downloadmeta-openembedded-b0ae995bc813aae651a94092c035a8f5d5253c22.tar.gz
ninja: support target builds
Extend the recipe so that it supports target builds. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/ninja')
-rw-r--r--meta-oe/recipes-devtools/ninja/ninja_1.6.0.bb (renamed from meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb)17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb b/meta-oe/recipes-devtools/ninja/ninja_1.6.0.bb
index c00710afd5..4d6c47e202 100644
--- a/meta-oe/recipes-devtools/ninja/ninja-native_1.6.0.bb
+++ b/meta-oe/recipes-devtools/ninja/ninja_1.6.0.bb
@@ -3,23 +3,28 @@ HOMEPAGE = "http://martine.github.com/ninja/"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
-DEPENDS = "re2c-native"
+DEPENDS = "re2c-native ninja-native"
-inherit native
-
-SRCREV="484c16336f19bd8970bb6e75322d61b92a229899"
+SRCREV = "484c16336f19bd8970bb6e75322d61b92a229899"
SRC_URI = "git://github.com/martine/ninja.git;branch=release"
-S="${WORKDIR}/git"
+S = "${WORKDIR}/git"
do_configure[noexec] = "1"
+do_compile_class-native() {
+ ./configure.py --bootstrap
+}
+
do_compile() {
- python ${S}/configure.py --bootstrap
+ ./configure.py
+ ninja
}
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/ninja ${D}${bindir}/
}
+
+BBCLASSEXTEND = "native"