aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/nodejs
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-09 10:20:11 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-09 10:20:11 +0100
commite5d7b0b90c71b986cdda3319b2a3be03254144b2 (patch)
tree7f1b8032ec1b7305161be1cf65fdd16fdd03f467 /meta-oe/recipes-devtools/nodejs
parent82a577eb926ecf00709dad05ec4c5e0242f5e673 (diff)
downloadmeta-openembedded-e5d7b0b90c71b986cdda3319b2a3be03254144b2.tar.gz
nodejs 0.4.2: make npm and node-waf work
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/nodejs')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb
index 726e88c860..0e776e0389 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.4.2.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://nodejs.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=6394136134ac02d730a7302418c94fb6"
-PR = "r1"
+PR = "r2"
DEPENDS = "openssl"
@@ -39,5 +39,7 @@ do_install () {
DESTDIR=${D} oe_runmake install
}
+RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
+
FILES_${PN} += "${libdir}/node/wafadmin"
BBCLASSEXTEND = "native"