aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorSlater, Joseph <joe.slater@windriver.com>2019-05-21 13:40:22 -0700
committerKhem Raj <raj.khem@gmail.com>2019-05-21 17:52:23 -0700
commit3327944ba5c3450ea36ce0bf7d08299f090fe87d (patch)
tree90b7bcc567d78bc3a2ec978f3e2c81d885c46c46 /meta-oe/recipes-devtools/php
parent33d578bda52b1b15026aa8d4416770a52d0fc057 (diff)
downloadmeta-openembedded-3327944ba5c3450ea36ce0bf7d08299f090fe87d.tar.gz
php-7: mark two tests as expected to fail
The output is reasonable, but not what is expected. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php/xfail_two_bug_tests.patch34
-rw-r--r--meta-oe/recipes-devtools/php/php_7.3.4.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php/xfail_two_bug_tests.patch b/meta-oe/recipes-devtools/php/php/xfail_two_bug_tests.patch
new file mode 100644
index 0000000000..21057439c9
--- /dev/null
+++ b/meta-oe/recipes-devtools/php/php/xfail_two_bug_tests.patch
@@ -0,0 +1,34 @@
+php-ptest: xfail two tests
+
+If and when these tests are modified to expect the correct output, they will
+succeed and generate warnings in the test summary. This patch can then be removed.
+
+Note that we add a closing '?>' to one test so that it can be executed directly by php.
+
+Upstream-Status: Pending
+
+Signed-off-By: Joe Slater <joe.slater@windriver.com>
+
+
+--- a/tests/basic/bug71273.phpt
++++ b/tests/basic/bug71273.phpt
+@@ -16,6 +16,8 @@ Bug #71273 A wrong ext directory setup i
+ var_dump(preg_match(",.+a[\\/].+[\\/]w.php_kartoffelbrei.dll.+,s", $out));
+ ?>
+ ==DONE==
++--XFAIL--
++Output is int(0), not int(1)
+ --EXPECT--
+ int(1)
+ ==DONE==
+--- a/tests/run-test/bug75042-3.phpt
++++ b/tests/run-test/bug75042-3.phpt
+@@ -8,5 +8,8 @@ display_errors=1
+ nonexistentsharedmodule
+ --FILE--
+ <?php
++?>
++--XFAIL--
++No warning message printed.
+ --EXPECTF--
+ PHP Warning: PHP Startup: Unable to load dynamic library '%snonexistentsharedmodule.%s' %A
diff --git a/meta-oe/recipes-devtools/php/php_7.3.4.bb b/meta-oe/recipes-devtools/php/php_7.3.4.bb
index 1a5c9760de..4e577df18c 100644
--- a/meta-oe/recipes-devtools/php/php_7.3.4.bb
+++ b/meta-oe/recipes-devtools/php/php_7.3.4.bb
@@ -11,6 +11,7 @@ SRC_URI_append_class-target = " \
file://pear-makefile.patch \
file://phar-makefile.patch \
file://0001-opcache-config.m4-enable-opcache.patch \
+ file://xfail_two_bug_tests.patch \
"
SRC_URI[md5sum] = "efb58aea95a66738d871f83ec55fec6f"